Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a simple pptp setup on our windows 2k3 server. So far all clients can connect just fine, mac and windows.

However I tried connecting an ubuntu server using pptp and the connection is fine I get an IP. From the 2k3 server I can ping the remote ubuntu server and vice versa. However, I cannot ping other machines on the LAN local to the VPN Server. <--Edited in response to Zoredache

I'm not sure if I have something misconfigured somewhere. Anyone have any experience with pptp on Ubuntu Server?

Maybe something I need to set up routing after connecting?

Under the win2k3 policies we just have a usergroup of users able to access the VPN and other machines on the NET. The user connecting is part of that group.

Update in response to questions below:
Output of route before connecting vpn

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
66.104.92.192   *               255.255.255.224 U     0      0        0 eth0
default         ip66-104-92-193 0.0.0.0         UG    100    0        0 eth0

Out of route after connecting vpn

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.60    *               255.255.255.255 UH    0      0        0 ppp0
66.104.92.192   *               255.255.255.224 U     0      0        0 eth0
default         ip66-104-92-193 0.0.0.0         UG    100    0        0 eth0

I'm using pptp on Ubuntu 8.04 LTS My global config file on the ubuntu server and my connection config file:

# PPTP Tunnel configuration for tunnel CSTS MotherShip
# Server IP: xxx.xxx.xxx.xxx #masked for security
name shai
file /etc/ppp/options.pptp
require-mppe
require-mppe-128

/etc/ppp/options.pptp doesn't exist

In response to Zoredache: I don't need LAN machines on the VPN servers side to access anything but the remote ubuntu pptp client. On the Ubuntu machine's LAN, other machines don't need to access it.

Have you enabled the ppp option to set the tunnel as the default gateway in the pptp client?
I'm looking where to enable that option. I'm using pptp 1.7.0

Another Update
After conntecting via VPN, on the Ubuntu server I ran:
route add default gw 192.168.1.1 and got back SIOCADDRT: No such process. 192.168.1.1 is the router on the LAN local to the VPN server.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

What are you using for a pptp client on Ubuntu? Have you enabled the ppp option to set the tunnel as the default gateway in the pptp client? When the VPN is enabled on the Ubuntu server do it still need to be usable from the network that is local to the Ubuntu server? If so you won't want to set the VPN as a default gateway and you will probably want to statically define a route.

However, I cannot ping other machines on the local LAN.

Which local lan are you talking about? Are you talking about the lan local to the Ubuntu server, or the lan local to the VPN server?

If you need clients that are on the same network as the VPN server to be able to access other hosts on the Ubuntu server's lan you will need to add a route on both sides. You will also need to have address space that doesn't conflict between the two networks.

share|improve this answer
    
please see my comments above –  shaiss Oct 1 '09 at 18:19
    
Thank you for pointing me in the right direction. The key was to add the folowing route add default gw 192.168.1.xxx after the vpn connection was established. xxx being our VPN servers IP. Thank you! –  shaiss Oct 1 '09 at 18:32

What's the output of route on the Ubuntu server? What's some more information about your VPN? Which pptp client are you using on Ubuntu?

share|improve this answer
    
please see my comments above –  shaiss Oct 1 '09 at 18:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.