Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been tasked with getting analysis services running on a machine that has sql server 2005 on it. I should say that I'm primarily a developer not an admin so bear with me. Also, i am not the developer who wrote the analysis services code (not sure why i'm the one stuck with this:) ). Anyway, it seems that analysis services and sql server interfere with each other.

When I first started analysis services everything was fine. The sql server app and analysis services app both worked ok. After a reboot, the sql server app didn't work right. It would connect to the database, but when i listed the databases (using query analyzer or the application) it would list out the analysis services databases, not the sql server databases. It was like the analysis services server had replaced the sql server. Sql management studio could see both servers just fine so I know the sql server was running. Then, I stopped analysis services, restarted sql server and started analysis services again and both apps worked again. What concept am I missing? Are analysis services and sql server waiting on the same port?

tia, don

share|improve this question

It is possible that you don't have the service starting in automatic. Take a look at the Surface Area Configuration for Features tool.

See this document for more information.

share|improve this answer

I'm sure a DBA will provide a better answer, but I'm wondering if your issue has to do with having to connect to a specific SQL Instance (named vs. default) for Analysis services, or even a port #

Possibly Helpful Article...

share|improve this answer
thanks for the link. its a strange situation. the port for analysis services is set to 0 (meaning the default of 2383 should be used) and i'm not sure how the app (which talks to the server on port 1433 using dblib and odbc - depending on the app) ends up getting connected to the analysis services server instead of the sql server. i'm not understanding something fundamental, i think). – Don Dickinson May 11 '09 at 15:25

IS this part of a vendor application? Some applications will create a couple of databases then abstract them into cubes in Analysis server on the same machine - SAP BPC does this

Check how many instances of SQL you have installed Check if you are just seeing databases with the same names as the cubes in Analysis Services

share|improve this answer


If you are using SSMS to connect, it allows for you to connect to the Database Engine or the SSAS instance. Many times I have connected to the wrong instance using SSMS simply by clicking through a couple of screens too quickly.

share|improve this answer
though i've done this too. that's not what's happening. i have code using odbc and dblib that tries to connect to the server on port 1433 ... it ends up seeing database on the wrong server. as an addendum, last time i rebooted, it connected to sql server not analysis services. seems to be some kind of startup order problem. perhaps random:( – Don Dickinson May 20 '09 at 14:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.