Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem with Win7 & VirtualPC - every time I start up a virtual machine, it appears to start fine, and then about 10 seconds into the boot process, my laptop either BSOD's or just hangs.

I have a Dell Inspiron 1721 notebook that i've been running the x86 version of Win7 on - and have had the issue with both build 7000 & 7100. I also have the issue with the Windows Virtual PC beta and with the Virtual PC 2007 product.

I've tried to use WinDBG to get what I can out of the minidump files - but i'm not sure if I have that set up correctly. Here's what I get from that...

CLOCK_WATCHDOG_TIMEOUT (101) An expected clock interrupt was not received on a secondary processor in an MP system within the allocated interval. This indicates that the specified processor is hung and not processing interrupts. Arguments: Arg1: 00000061, Clock interrupt time out interval in nominal clock ticks. Arg2: 00000000, 0. Arg3: 807c4120, The PRCB address of the hung processor. Arg4: 00000001, 0.

--Anyone know what I can look at to correct this? As a developer, i REALLY miss my virtual PC.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

This was/is a known issue on Windows Server 2008 Beta, so it may be related.

Try upgrading your BIOS, or just wait for a fix from Microsoft.

share|improve this answer
    
I've checked the BIOS, there is no newer version. Do you know of there are any workarounds? –  Scott Ivey May 11 '09 at 15:50
    
Not that I know of, sorry :( –  Ivan May 11 '09 at 19:23
add comment

This may be caused by a bug in Intel Core i-7 (or other processors in the same family).

I had the exact same problem (running Windows Server 2008 R2 and Hyper-V). Whenever I ran an instance of a virtual machine, it crashed after a few minutes.

Fortunately, there is a hotfix available for this, see this KB-article

After applying this hotfix, the problem goes away.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.