Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using a Win7 computer that isn't joined to the domain. I want to be able to run a program, such as IE, under the domain user.

c:\> runas /noprofile /netonly /user:MyDomain\MyUser iexplore.exe

It asks for my password and starts up IE just fine. When I go to a site that requires my domain credentials, it asks me for my user/password again. It says my domain is the name of my computer, instead of the user I'm running as. If I try this same thing on a computer that is already joined to the domain, it doesn't ask for the user/password.

How can I have it so IE doesn't ask my domain credentials again, since I'm already running as that domain user?

When running SQL Server Management Studio, I'm able to connect to databases on the domain just fine, so I don't know why IE is asking for my credentials again.

Thanks.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Do you have the "Automatic logon using current username and password" option enabled in IE?

  • Internet Options | Security Tab
  • Click Local Intranet Zone and then the Custom Level button
  • In Security Settings under Logon, make sure the option is selected
share|improve this answer
    
Yes, that is already turned on. –  Josh Close Oct 1 '09 at 13:32
    
Turn it off then unless you've manually added the site you're visiting to the Intranet zone. If you're not bound to AD your machine won't automatically be configured using GPO so it won't know the site you're visiting is in the Intranet –  Josh Budde Oct 1 '09 at 14:38
    
I set the setting to "Automatic logon with current user name and password" and it worked. –  Josh Close Oct 1 '09 at 15:06
    
If you change your answer to "Automatic logon with current user name and password", I will mark your answer as the accepted answer. –  Josh Close Oct 1 '09 at 15:08
    
Done. Right, the Intranet zone one is the one my brain always goes to since that's what I use all the time... sorry 'bout that! –  squillman Oct 1 '09 at 15:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.