Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When accessing a server running Samba, Mac OS X opens a login window prompting for a username and password. With the correct username and password, I'm able to login and read/write to shares.

Using Windows XP, a similar login window opens, but the username and password appear to fail. After entering both, I click the OK button, the window flashes and reappears. When it reappears the username field now contains, theSambaMachineName\username and the password field is blank.

I'm guessing this is a common problem with Windows XP accessing Samba shares, but searching for general windows to samba problems hasn't been helpful. Anyone know the cause to the problem?

share|improve this question

6 Answers 6

Typically when you get that kind of prompt, the XP box is looking to authenticate against something and failing. Does this network have a domain? If so, is the OS X machine part of that domain?

The login you provide must match either a domain account or an account that exists on the machine it's connecting to that has permission to that share.

For example, let's say I have a domain called, "MyDomain.local" with a server called, "MyServer". If the account you're using exists in the domain, you'd have to type in the username like this: "MyDomain\Username". If the account does not belong to the domain and only exists on the server, then it'd be "MyServer\Username".

Based on the fact that the XP box is coming back with the name of the server, I'm guessing that the account does not exist on the server.

share|improve this answer

you need to set encrypt passwords = true in the global section of smb.conf, because windows sends the passwords encrypted

share|improve this answer

Is the valid username part of a domain or is it a local account on the computer that is hosting that share?

The second request for valid credentials by Windows XP is either meaning the username and password you entered is incorrect or they don't have access to that share.

share|improve this answer
    
The Windows system is on a domain. OSX and Samba are not. I've since learned that I can create a mapped drive on Windows XP and within that window there is a link to connect as a different user. Using that approach I can connect from XP to Samba share. –  Michael Prescott Oct 1 '09 at 19:38

You say Windows is on the domain, but OSX and Samba are not; I'll take a guess you're also saying your Samba server is Linux based? Let us know what your password options are set to in smb.conf; would "security = server" be a good guess what you have running? And what is the value of your 'workgroup' line - the same as the domain?

If the above is true, check your linux server to see if 'winbind' is running - if so, turn it off as it's trying to use your domain. I have a setup similar to yours and the Windows XP guests have a problem accessing this non-domain Red Hat samba server if winbind is running, even though security = server on it. (/etc/init.d/winbind stop; chkconfig winbind off)

share|improve this answer

Is your Samba server configured to only accept plaintext username/passwords by any chance? Windows will refuse to do this by default, whereas Mac OS X and Linux may not.

share|improve this answer

Had the same problem with XP clients not being able to connect while Windows 7 was fine. The solution I found was to change the following registry key on the XP machines:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\LMCompatibilityLevel

Windows XP: set to: 3
Windows Vista and Windows 7: set to: 1

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.