Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am unable to get mount.cifs to respect the user flag passed to mount. The entry in /etc/fstab is

//10.0.1.205/rm /home/robert/remote/rm cifs user,uid=robert,gid=users,file_mode=0644,dir_mode=0755,credentials=/etc/samba/navision,rw,noauto 0 0

but when executing

robert@rm:~/remote> mount rm

I receive

mount error(1): Operation not permitted
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
share|improve this question
add comment

3 Answers

up vote 5 down vote accepted

It looks like mount.cifs has to be setuid to allow normal users to mount shares.

http://www.samba.org/samba/docs/man/manpages-3/mount.cifs.8.html

"It is possible to set the mode for mount.cifs to setuid root to allow non-root users to mount shares to directories for which they have write permission."

share|improve this answer
    
    
That is only for Ubuntu - Debian has changed its behavior back to setting mount.cifs setuid (see here and here) based on upstream. In any case, it was still possible to set it setuid, just not recommended. –  James Curbo Feb 22 '13 at 17:31
add comment

Do NOT name a drive volume "rm" under Linux. You are asking for disaster.

share|improve this answer
1  
Tell that to my system administrator team. Unix users are created by initials. Guess what my user is :-) –  Robert Munteanu Nov 6 '10 at 8:42
add comment

This is the format I think you want to use-it looks like maybe you're using the wrong user deceleration in the command pasted above

//192.168.44.100/share_name /path_to/mount_point cifs username=server_user,password=server_password,_netdev,uid=client_username,gid=users 0 0
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.