Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Disclaimer: I'm a complete IIS noob, I've only dealt with Apache servers.

I have been given "full admin privileges" to RDP to a 3rd party server with IIS 7.0.6000 running on Windows Server 6.0 SP1. I'm trying to edit files in C:\inetpub\wwwroot\webres\ however the directory has Read-Only permissions set.

In IIS manager I can Edit the permissions for the directory and uncheck the Read-Only box... however when I do it, it keeps reverting back.

If I try to edit a file with VIM it opens it in read-only obviously. The server is running, am I supposed to stop it in order to edit stuff or do I actually need to contact the administrator and tell them I need more permissions for my user which supposedly has full admin privileges?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

The "read only" file attribute doesn't apply to directories, the bug of that checkbox being checked (and reverting to that) has been around for quite a while.

You should check NTFS permissions on the folder and files.

share|improve this answer
add comment

Soo I ended up right clicking on the webres folder, properties, security tab, I selected one group of users and edited the permissions for the whole group, checked Modify and Write.. maybe the Admin forgot to do that but I can now read/write :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.