Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a need to have lots of internal SSL sites, so I need lots of internal IPs. With some helpful advice here on this site, I learned I can change my subnet mask to raise the limit of hosts that I have.

I've got my statically-configured servers changed over from to But my DHCP-enabled computers all get the subnet mask automatically from my DHCP server. The DHCP server itself is now on But when I renew the lease on a DHCP-enabled client, it still gets the subnet mask I want them all to get automatically.

Note: I would like all of my computers to be able to talk to each other. So I would like them all to have the subnet mask. However, I do not need to increase my DHCP scope (as far as I know). I am fine with it handing out only IPs within 192.168.0.x. I just want those computers that it serves to be able to communicate with the computers who have IPs such as

If I right-click my Scope in DHCP (I have only one DHCP server with one scope), I can see the start and end IP addresses are currently and respectively (and I have an exclusion range defined elsewhere). However, subnet mask is grayed out. I suppose there is a distinction, though. The subnet mask here likely defines the subnet mask of the range I am defining, which I don't think I need to change. I just want the DHCP server to hand out the newly increased subnet mask to clients that are asking for DHCP service.

So how do I tell my DHCP server "Hey man, we do things differently now. Tell people the subnet mask is" I tried saying it out loud but the server was unresponsive.

Update: I am going to re-create the scope as suggested. You are probably all correct but I will set an answer after I confirm that it works. Or confirm that it would probably work but I am too stupid to get it to work. :)

Update 2: I have a new Windows Server 2008 R2 Server that I am migrating services to. I took this opportunity to install the DHCP role over there and create the new scope on that server instead. When I added the role, the setup wizard was very clear about which IPs were part of the first scope you were creating, and what would get served as the subnet mask. I simply followed the directions. I then authorized the new DHCP service, and De-Authorized the old one. Everything is great now.

Even though I had many DHCP reservations, the whole process only took a half hour. I would have spent as much time fiddling with an import/export process.

share|improve this question
"I tried saying it out loud but the server was unresponsive." lol – wfaulk Oct 2 '09 at 18:03
By the way, the Windows DHCP server is such a huge piece of junk. This is just one of the many reasons why. – wfaulk Oct 2 '09 at 18:27
up vote 1 down vote accepted

Changing the subnet mask of a scope isn't possible. If you don't have a lot of reservations the simple solution would be to simply create a new scope and disable the old one.

Update, here is an howto that describes how to export/import reservations. I haven't tried this myself though.

share|improve this answer
Yikes. I have nearly 100 reservations. This is an opportunity to get rid of a lot of them, though. I made them all before I understood DNS. – Chris Oct 2 '09 at 18:09
Nuke them 'til they glow. – squillman Oct 2 '09 at 18:09
In case you are wondering why I have so many reservations. It's because I have a lot of IPv4 devices that need special access rights through the firewall (ISA Server). For example, each of my Sonos nodes needs to be able to stream internet radio, but I don't want my other systems to be able to do that. ISA Server needs IP addresses for access rules, afaik. – Chris Oct 2 '09 at 18:23
I use them because I want my DNS server to have accurate and non-leftover data in it, yet also have IP addresses supplied by DHCP. I should probably just use a real DHCP server, since I have disabled all the broken Windows-specific parts of it. – wfaulk Oct 2 '09 at 18:43
I have used netsh as described in the article to move entire scopes from one dhcp server to another. This will work just fine. – Moose Oct 2 '09 at 20:05

You have to delete and recreate your scope. Have a look at this KB.

Best to just go home if you yell at your servers and they don't listen to you... Bad juju.

share|improve this answer

Sadly, you'll have to define a new scope. Might be easier to "migrate" the scope to the same computer and edit the intermediate file. Nevermind. Since they suggested you name that file dhcpdatabase.txt, silly me assumed that it was a text file. Turns out that it's some impenetrable binary blob.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.