Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Windows Server 2003 32-bit.

We have moved the server from one office to another, with a new external IP address.

The firewall/router is fine as we can connect a laptop to it with a static IP address and get straight out onto the internet.

However, the server is unable to open webpages - regardless of what browser we try.

We can ping external IP addresses okay and we can ping hostnames, which resolve to the respective external IP addresses okay.

The server has been restarted a number of times and we have also checked the specific cable going into the back of the server with a laptop. We also tested the other network card (of 2) with no success.

Any ideas(?) as we are really stuck!

share|improve this question

4 Answers 4

That's a bit odd. I wonder if your firewall / router has some ACLs that are only applying to the IP address assigned to the server computer.

I'd try something like:

TELNET www.google.com 80

First and see if you even get a TCP connection. If you get a blank window w/ a blinking cursor, type "GET / HTTP/1.0" (w/o quotes, and it won't echo) and press <ENTER> twice. See if you get back a response.

Set the server computer's IP address to the one that worked on the laptop computer. If it doesn't work, at that point, you'll have ruled out everything except for software on the server computer itself.

Edit: Okay-- I see in your comment on another post that you tried a laptop w/ the same IP that's currently assigned to the server and the laptop worked fine. That does sound like something is up w/ the server computer, then.

How did that TELNET do? That's going to isolate the problem to either the TCP/IP stack or the browser, depending on if the TELNET works or not.

When you open a browser and it's "trying to connect" run a "NETSTAT -a -n" and look for TCP connections outbound to port 80. I'd be interested to see if it's even trying to make an outbound connection or not.

share|improve this answer
    
Telnet via port 80 seems to time out even to a well known address such as Google's yet I can ping and resolve hostnames. –  ezwi Oct 3 '09 at 13:06
    
That's really odd. I'd probably throw "Network Monitor" or Wireshark on the box and see if it's really trying to send SYN's out to the 'net. (Network Monitor isn't all that wonderful, but it is built-in to the OS, so it's quick and clean to install / uninstall.) Was this thing ever behind a Microsoft ISA Server firewall? –  Evan Anderson Oct 3 '09 at 13:09
    
Successful pinging is testing if IP routing of ICMP packets and DNS resolutions are testing that UDP packets are being routed but Telnet and the browser are telling you that TCP traffic to port 80 is being blocked. This is most probably a firewall local to the server as you mention the laptop connected to the works fine. The failure to Telnet is telling you that even if you bypass any proxy by going straight to the port, TCP/IP is still blocked. Also check the ipconfig settings for the default gateway is what you expect. –  Stuart Woodward Oct 3 '09 at 14:19

just a hunch - do you have any http-proxy configured in your web browsers? what happens if you try to download website content using wget:

wget.exe http://yahoo.com

is it possible that you have some firewall on the windows server preventing outgoing tcp/80 requests?

share|improve this answer
    
No proxy server installed and no firewall enabled. We have a hardware firewall. I tested the laptop with the same cable from the back of the server with the same static IP address and it works fine so pretty sure it is the server itself. wget doesn't work, it is not a recognised command. –  ezwi Oct 3 '09 at 13:03
    
@ezwi - well - you need to get wget - i provided a link. but if you cannot telnet to port 80 - wget will not work neither. –  pQd Oct 3 '09 at 15:35

Do you by chance have host headers set on your site in IIS that refer to the old IP address?

share|improve this answer

I had the same issue and it got resolved by resetting the Windows Firewall rules policy back to default

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.