Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to setup postfix with imap on a vserver. Now, I'm trying to create the first user/mailbox. The vserver runs Debian. I tried to login to the Cyrus administration console with cyradm, but to no avail. Search results on the internet advise me to use the cyrus account. The following steps are performed:

passwd cyrus

Let's pretend the password will be set to pass1234. ;-) Then - logged in as root - run:

cyradm -u cyrus localhost

Then enter the password 'pass1234', this yields:

Login failed: authentication failure at /usr/lib/perl5/Cyrus/IMAP/Admin.pm line 119
cyradm: cannot authenticate to server as cyrus

The same happens if I do a 'su - cyrus' before, i.e. not running as root.

All I want to accomplish now is to get into that console so that I can create a mailbox. Are there any other places (config files) or tools that I can use to manage Cyrus specific passwords?

Thanks for any hints,

Andre

share|improve this question

2 Answers 2

up vote 0 down vote accepted

You must authenticate as an admin user as defined in the "admins" or "imap_admins" options in /etc/imapd.conf . You should pay attention to the "sasl_mech_list" option as well and be explicit in the SASL authentication mechanism option to cyradm to avoid problems. E.g. if you specified PLAIN in "sasl_mech_list" you should specify it in the command line:

cyradm --auth PLAIN --user cyrus localhost

I prefer to specify an autocreatequota in imapd.conf to allow the creation of the mailbox through IMAP; it's a lot easier to script tha using cyradm during account creation and verification, and it could even be done manually if necessary.

Hope this helps.

share|improve this answer
    
Although this did not exactly solve my problem, I accept this answer. My problem was set I had to specify the SASL password when cyradm asked for the IMAP password, not the linux account password. In my case, I could set it with /usr/sbin/saslpasswd2. Thanks, codehead –  Andre Oct 3 '09 at 16:58

In my case I had set saslauthd as the only option for sasl_pwcheck_method in imapd.conf as I wanted to authenticate my users trough OpenLDAP. But, for some reason cyradm doesn't communicate with OpenLDAP. Adding auxprop solved it for me:

/etc/imapd.conf:

sasl_pwcheck_method: saslauthd auxprop
sasl_auxprop_plugin: sasldb

Then I had to reset the password of cyrus like Andre stated in his comment:

saslpasswd2 cyrus

And right after that I could log in using:

cyradm --user cyrusadmin localhost
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.