Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows XP SP2 machine with Hamachi service running. Usually I connect to it using Remote Desktop, and when I disconnect I can't connect to it again because the Hamachi VPN is down. How to prevent the Hamachi service to stop?

I am sure that Hamachi is configured as an automatic service.

share|improve this question

5 Answers 5

up vote 4 down vote accepted

If Hamachi is configure to run as a service, then it should not matter whether you just disconnect from the RDP sesssion, or log off, as it should be running in the background. You should check the services MMC to see that the service is there, and that it is running.

share|improve this answer

Apparently the free version of Hamachi requires the GUI to be running in order to operate. When you disconnect your RDP session the free version of Hamachi will disconnect. The workaround appears to be to run the following command instead of disconnecting.

tscon 1 /dest:console

This may need to be run as administrator. This will transfer your session back to the local machine. Also note that when the session is transfered back to the local machine it will not be locked and will be available to anyone with physical access to the machine.

share|improve this answer
    
Very interesting. It looks like you are right: "So, in the hopes of converting more of you into paying customers, we’re making a small change to Hamachi: unless a computer is part of a paid network, you need to be logged in and running the Hamachi UI on your desktop in order to allow it to function. If no user is logged on to the computer then – even though the Hamachi service or daemon is active in the background – it will not go online in any networks that it may belong to. We believe this a fair change..." b.logme.in/2012/11/07/changes-to-hamachi-on-november-19th –  Austin ''Danger'' Powers Aug 20 '13 at 2:46

Just add this in a .bat script:

tscon 1 /dest:console
rundll32.exe user32.dll, LockWorkStation

The first line transfers the remote session to the local desktop and the second line, locks it. Instead of disconnecting, just run the bat script.

share|improve this answer

If you close the remote desktop session without logging off it shouldn't be an issue. If your using the microsoft rdp client just click the "X" at the top bar of the screen.

The only other thing I could think of is maybe the hamachi client is set to auto-disconnect if idle for X minutes. I'm not even sure if hamachi has that option, I've never really looked.

share|improve this answer
    
I usually use the close(X) button –  Jader Dias May 11 '09 at 18:14
    
Hmmm the Hamachi shouldn't see a difference, the only thing that effectively happens when you close an rdp session that way is the computer locks. I would poke around the settings a bit. I don't have access to a Himachi client where I'm at. –  TrueDuality May 11 '09 at 18:55
1  
Have you tried logging to see what exactly is going on? Go into Hamachi Preferences > System > Enable Diagnostic Log. Logs are place in %APPDATA%\Hamachi (your Hamachi configuration folder) and are rotated when they reach 8MB. –  TrueDuality May 11 '09 at 19:12

When I stopped to close the window through the X button, and started to Disconnect, then the problem not occurred again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.