Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had exsi 3.5 running just fine, the upgrade to 4 failed ( i thought it would so everything is backed up ). but it did boot just could not import the data store

So i did a fresh install of ESXi 4. Now it says failed to find boot device.

Not sure why. i have wiped the disk, the controller is a adaptec 3405, it worked fine in 3.5 and when i upgrade to 4 it did boot.

Now it just hangs at loading vfat. then the failed to find boot device.

Any ideas?

share|improve this question

migrated from stackoverflow.com Oct 4 '09 at 21:45

This question came from our site for professional and enthusiast programmers.

    
What hardware are you using? –  tegbains May 14 '10 at 0:00

1 Answer 1

After getting ESXi 4 installed on a flash device i was still not able to create a datastore on the array. After searching around i found that disabling : Intel VT for direct in the BIOS cleared up the problems.

Probably disabling this from the start would have not had to do the reinstall

share|improve this answer
6  
That's REALLY wierd, normally you'd WANT VT enabled - are you sure all your components are on the v4 HCL? –  Chopper3 Jan 1 '10 at 12:31
    
Agreed - much to my chagrin, a bunch of devices were dropped off the HCL in the ESXi v4. –  EEAA Apr 13 '10 at 3:12
1  
Is that really VT that is disabled? Or VT for Directed IO (VT-d)? Since it is a drive issue, I'm willing to bet that it is a Directed IO problem. –  Jed Daniels Jan 3 '12 at 2:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.