Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My problem is showing on a Hyper-V setup, but is not strictly a Hyper-V problem. Hyper0V is exposing the symptom.

I created a fixed size file on a drive in the host that almost fills the physical volume. This is causing "Low Disk Space" messages. Which, in turn, appears to be causing the guest VM to go to "Pause-Critical" status.

How can I make Server 2008 and/or Hyper-V stop doing this check? Or, will I have to reduce the size of my fixed size files(s)?

share|improve this question
    
Should have mentioned that "Low Disk Space" message is occurring on the Hyper-V host machine for a drive that contains only fixed size virtual disk (vhd) files. The guests VM are being paused when the error occurs on the host. The guests themselves are not low on space and are not failing other than being paused by Hyper-V. –  Jim R Oct 5 '09 at 10:43
    
Wow, that's a pretty crappy default response. Hopefully Microsoft fixes that in the next release to make that optional. –  mrdenny Oct 5 '09 at 22:57

2 Answers 2

up vote 1 down vote accepted

Start regedit
Nagivate to this key:

 HKEY_Current_User\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Add the DWORD value NoLowDiskSpaceChecks and set it to 1.

This is a user setting, so you'll have to possibly add it to the default user profile and any existing users you've created. That or create an administrative template and apply it at the Active Directory level.

I'm guessing this is not going to solve your guest os going into the pause-critical status. Something else is happening here that's doing this. Maybe the hyper-v guest os tools are doing this because it thinks the host is out of disk space? try uninstalling them?

share|improve this answer
    
Thank you that is what I was looking for. I actually resolved the problem in this particular instance by switching from a Fixed-Size file to Pass-Thru disk. That cannot always be done , bit it worked because I could dedicate the whole disk (actually a raid-set) to a single VM. –  Jim R Oct 5 '09 at 21:26
    
I attempted to 'Vote up' your answer, but I do not seem to have adequate reputation. –  Jim R Oct 5 '09 at 21:33
    
I believe you need +50 rep to upvote. –  Nick Kavadias Oct 5 '09 at 21:57

You are getting the error because having low disk space can be a problem for Windows. It can stop Windows from being able to use the page file, write temporary files etc. You really should be fixing the low disk space error, not trying to disable it, as it may cause you problems. Is there any reason this file has to be that size, can it be smaller, or as its a virtual machine, can you make the drive bigger?

share|improve this answer
    
Low space message is coming from G: drive. Windows files, swap file, temp files etc. are not located there. Ideally, I would prefer to only eliminate checking for the drives that I am exclusively using for fixed size virtual disks. I seems absurd to artifically limit the amount of space I am using in this situation. –  Jim R Oct 5 '09 at 10:36
    
This is a bogus response, I have a 4TB CSV RAID with 25% free for virtual machines and Hyper-V 2008r2 SP1 still pauses or saves virtual machines with this ridiculous warning during backups when snapshots are used and yes snapshots are stored in the same location as the rest of the VHDs and during backups I still have 25% free which is oh, carry the one, divide by Pi, oh 1TB free. How does an explorer registry key affect Hyper-V running as a service under SYSTEM? I don't see this as being relevant at all and Microsoft's explanation is just as ridiculous. support.microsoft.com/kb/2486243 –  zman Nov 13 at 20:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.