Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having a problem where for some reason, Remote Desktop (RDP) continually gets disabled on a Win2003 server. Our networking team is not doing this, so as far as I know it is not a security script that is running, etc.

In any case, I am able however to access the remote registry, since I am an administrator on the site. My question is, what registry key do I need to change in order to re-enable remote desktop?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Under Server 2003 the key is:

HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\fDenyTSConnections

change it from 1 to 0.

share|improve this answer
    
Thanks - though note that a reboot does not appear necessary. Worked as soon as I changed the key. –  Sam Schutte May 11 '09 at 19:30
    
edited accordingly –  John T May 11 '09 at 19:31
2  
I'd add this setting to Group Policy Preferences if you want it enabled on all your servers. –  aharden May 11 '09 at 20:22

I'm not sure which key it is, but you could use the following utility. Or use the following utility and run RegMon to find out which key.

http://www.intelliadmin.com/blog/2006/06/remotely-enable-remote-desktop.html

share|improve this answer
    
downvote? dang... oh well, I really like that tool... :D –  Brandon May 11 '09 at 19:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.