0

I hope someone can help me. I have a AT&T 2wire gateway with a cisco router attached to port 3 of the AT&T 2 wire. I'm using the CISCO as a separate network and lab. Below is sketch of my network and the show run config output of the router. My problem is that I'm trying to use NAT to get to the internet from the cisco router through the AT&T wire. Also when I do a show nat translation does not nothing shows in the table as if nothing is being translated and I cannot get to the internet but can ping everything on both networks, 10.1.1.0. 192.168.1.0. Where am I going wrong.

AT&T 
  |
  |
192.168.1.111
  |     fa0/0 Outside NAT
  |
   CISCO Router
              fa0/1 10.1.1.1 Inside NAT



    Router#show running-config
    Building configuration...

    {Current configuration : 1039 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    ip dhcp excluded-address 10.1.1.1 10.1.1.10
    !
    ip dhcp pool Test_Lab
       import all
       network 10.1.1.0 255.255.255.0
       default-router 10.1.1.1
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
     ip address 192.168.1.111 255.255.255.0
     ip nat outside
       duplex auto
     speed auto
    !
    interface Serial0/0
     no ip address
     shutdown
     !
    interface FastEthernet0/1
     ip address 10.1.1.1 255.255.255.0
     ip nat inside
     duplex auto
     speed auto
     !
     ip nat inside source list 101 interface FastEthernet0/0 overload
     ip http server
     ip classless
     ip route 0.0.0.0 0.0.0.0 192.168.1.0
     ip route 10.1.1.0 255.255.255.0 FastEthernet0/0
     ip route 10.1.1.0 255.255.255.0 192.168.1.0
     !
     !
    access-list 101 permit ip 10.1.1.0 0.0.0.255 any
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end






Router#show ip route
Gateway of last resort is 192.168.1.0 to network 0.0.0.0
 10.0.0.0/24 is subnetted, 1 subnets
 S       10.1.1.0 is directly connected, FastEthernet0/0
   [1/0] via 192.168.1.0
 C    192.168.1.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 192.168.1.0

Changed ip route to AT&T PORT IP ADDRESS WHICH CISCO ROUTER is cabled to

    Gateway of last resort is 192.168.1.93 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 192.168.1.93

4 Answers 4

1

I would assume that the problem is in your routing table. E.g.,

ip route 10.1.1.0 255.255.255.0 FastEthernet0/0
ip route 10.1.1.0 255.255.255.0 192.168.1.0

According to these commands, all IP packets to 10.1.1.0 network will be redirected either to FastEthernet0/0 (which means back to 192.168.1.111) or to 192.168.1.0 (which probably means nowhere, since this is address of the network, not an address of a gateway). So no IP packet could reach 10.1.1.0 network.

However, I'm not sure if this is a problem, since 10.1.1.0 is directly connected and it still could work correctly. Could you please add your routing table to the question (Output of 'sh ip route')?

1

Im guessing the AT&T has a LAN side IP address, in which case you need to create a default route on the cisco router that sends all traffic with a destination of unknown networks to the lan side interface on the AT&T box.

ip route 0.0.0.0 0.0.0.0 IPOFAT&TLANINTERFACE

This means the next hop of any 'unknown network' traffic such as traffic to the internet will be directed to the AT&T router which in turn fowards the traffic to its upstream gateway.

You do not need to perform NAT on the cisco unless you can operate the AT&T in bridge mode and assign your public IP to an interface on the cisco.

7
  • I guess he tried to do it already with 'ip route 0.0.0.0 0.0.0.0 192.168.1.0', although there should be 192.168.1.111 and not 192.168.1.0. Still would like to see the full routing table to be sure about what happens. Aug 17, 2015 at 12:11
  • @AndreySapegin Yeah correct, that 192.168.1.0 needs to be the LAN side interface of the AT&T box, but in the diagram in his post, I am not sure whether 1.111 is fa0/0 on the cisco or an interface on the at&t. Aug 17, 2015 at 12:34
  • @AndreySapegin if I understand you correctly I need to have a route to the ip address of FA0/0 interface which does go to the at&t. I will try once I get home.
    – Blake
    Aug 17, 2015 at 20:53
  • 1
    @Blake not quite, you need to have a route to the lan interface of the at&t which is connected to the Fa0/0 interface. You don't route to the interface you want to exit from, you route to the destination IP and traffic will leave via the interface that is on that network. Aug 17, 2015 at 20:57
  • Below is my show ip route
    – Blake
    Aug 18, 2015 at 0:59
0

Might be that I've misunderstood your problem but it sounds like you can't even ping destinations on the Internet from your Cisco router which then would be the main problem and not NAT. Since you can see translations with "show ip NAT translations" it sounds like that part of the config is fixed.

Try to ping destinations on the Internet from a source interface of Fa0/0. Do you have other devices apart from the Cisco router connected to the AT&T device and can they reach the Internet?

Edit: Seems like you've used the wrong IP for default gateway. To find the correct IP you can either use the Laptop or the Cisco Router.

On Laptop: Connect it to the network and make sure it has DHCP turned on and not static IP. Use ipconfig to display your assigned Default Gateway next to your assigned IP address. Might look similary to this or it could display more information but regardless you should be able to find the address for your default gateway in the output from ipconfig.

https://i.stack.imgur.com/ezGAF.jpg

Use the IP of the default gateway for your static route on the cisco router.

Alternative 2: On Cisco router you could do the same thing:

enable
configure terminal
interface FastEthernet0/0
ip address dhcp
exit
no ip route x.x.x.x (make sure to remove every static route in your config just to have a more clean config)
end
show ip route

In the output you should see Gateway of last resort is x.x.x.x and that is the IP of your AT&T inside interface

When you have found which IP is your gateway you can switch back to static IP for your router and use that IP as a default route.

7
  • Jimmy when I use any device beside the CISCO router I can ping anything on the internet. Could this be the problem, the static route that is going to S* 0.0.0.0/0 [1/0] via 192.168.1.93 may not be the ip address that is on the port of the AT&T router. The way I got that IP address is by connecting a laptop to the port and then do a ipconfig and used that IP address thinking that it was the IP address of that port. But now that I think about it I actually mapped t the laptop IP address which is why I cant get to the internet. How do I find the IP Address of a port on AT&T 2wire
    – Blake
    Aug 20, 2015 at 0:09
  • @Blake If your laptop can reach the Internet it means that it has got a valid default gateway configured. The output from "ipconfig" should among other things give you the values of IP Address or IPv4 Address and Default Gateway. Another way is if you change to DHCP on the Cisco router with "ip address dhcp" command under interface fa0/0. Then it should receive an IP address and a default gateway provided that you have DHCP enabled on the AT&T device which I assume. You can view that default route if you remove the static ones and issue "show ip route".
    – Jimmy
    Aug 20, 2015 at 5:06
  • Hmm, I will try DHCP on the CISCO interface. I tried that using this link put did not do a static route to the ip address. Here is the link that I used.networking-newbie.blogspot.com/2008/10/…
    – Blake
    Aug 20, 2015 at 11:24
  • Jimmy are you saying to follow these steps router> enable router# configure terminal router (config) # interface ethernet 0/0 router (config-if)# ip address dhcp router (config-if)# no shutdown Then do a static route to the ip address that is given by the AT&T router.
    – Blake
    Aug 20, 2015 at 21:50
  • @Blake If you can't see default gateway from ipconfig you could try that. But don't make a static route, remove all configured static routes and then issue show IP route and see if you received a default gateway.
    – Jimmy
    Aug 21, 2015 at 4:05
0

I created a static route to the public IP Address on interface fa0/0. When I do a show ip int brief on the cisco router, I get a 192.168.1.254 IP address.

I connected a laptop to interface fa0/1 received a 10.1.1.1.11 as IP address from DHCP on the CISCO router and I'm able to get out on the internet. So look like its working.

Not the answer you're looking for? Browse other questions tagged .