Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Puppet 3.x using Foreman-installer.

I've following this guide after doing the following steps:

  • Installed a clean installation of CentOS 6.6.
  • Added foreman and puppet repos.
  • Ran yum update

Next, I've made sure the relevant repos are enabled:

[root@dev5-puppet01 ~]# yum repolist
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: centos.spd.co.il
 * epel: mirror.nonstop.co.il
 * extras: centos.spd.co.il
 * updates: centos.spd.co.il
repo id repo name    status
base CentOS-6 - Base   6,575                          
epel Extra Packages for Enterprise Linux 6 - x86_64          11,772
extras   CentOS-6 - Extras                                   35
foreman  Foreman 1.9                                         322
foreman-plugins  Foreman plugins 1.9                         173
puppetlabs-pc1   Puppet Labs PC1 Repository el 6 - x86_64    28
updates  CentOS-6 - Updates                                  254
repolist: 19,159

And issued the command to install foreman-installer:

[root@dev5-puppet01 ~]# yum install foreman-installer
Loaded plugins: fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: centos.spd.co.il
 * epel: mirror.nonstop.co.il
 * extras: centos.spd.co.il
 * updates: centos.spd.co.il
Resolving Dependencies
--> Running transaction check
---> Package foreman-installer.noarch 1:1.9.0-1.el6 will be installed
--> Processing Dependency: rubygem-kafo >= 0.6.5 for package: 1:foreman-installer-1.9.0-1.el6.noarch
--> Processing Dependency: rubygem-apipie-bindings >= 0.0.6 for package: 1:foreman-installer-1.9.0-1.el6.noarch
--> Processing Dependency: rubygem-highline for package: 1:foreman-installer-1.9.0-1.el6.noarch
--> Processing Dependency: ruby(abi) for package: 1:foreman-installer-1.9.0-1.el6.noarch
--> Processing Dependency: foreman-selinux for package: 1:foreman-installer-1.9.0-1.el6.noarch
--> Running transaction check
---> Package foreman-selinux.noarch 0:1.9.0-1.el6 will be installed
--> Processing Dependency: policycoreutils-python for package: foreman-selinux-1.9.0-1.el6.noarch
--> Processing Dependency: /usr/sbin/semanage for package: foreman-selinux-1.9.0-1.el6.noarch
---> Package ruby-libs.x86_64 0:1.8.7.374-4.el6_6 will be installed
--> Processing Dependency: libreadline.so.5()(64bit) for package: ruby-libs-1.8.7.374-4.el6_6.x86_64
---> Package rubygem-apipie-bindings.noarch 0:0.0.13-1.el6 will be installed
--> Processing Dependency: rubygem(rest-client) < 1.8.0 for package: rubygem-apipie-bindings-0.0.13-1.el6.noarch
--> Processing Dependency: rubygem(rest-client) >= 1.6.5 for package: rubygem-apipie-bindings-0.0.13-1.el6.noarch
--> Processing Dependency: rubygem(json) >= 1.2.1 for package: rubygem-apipie-bindings-0.0.13-1.el6.noarch
--> Processing Dependency: rubygem(oauth) for package: rubygem-apipie-bindings-0.0.13-1.el6.noarch
--> Processing Dependency: rubygem(awesome_print) for package: rubygem-apipie-bindings-0.0.13-1.el6.noarch
--> Processing Dependency: ruby(rubygems) for package: rubygem-apipie-bindings-0.0.13-1.el6.noarch
---> Package rubygem-highline.noarch 0:1.6.21-2.el6 will be installed
---> Package rubygem-kafo.noarch 0:0.6.11-1.el6 will be installed
--> Processing Dependency: rubygem(logging) < 2.0.0 for package: rubygem-kafo-0.6.11-1.el6.noarch
--> Processing Dependency: puppet < 4.0.0 for package: rubygem-kafo-0.6.11-1.el6.noarch
Package puppet-2.7.26-2.el6.noarch is obsoleted by puppet-agent-1.2.2-1.el6.x86_64 which is already installed
--> Processing Dependency: rubygem(clamp) >= 0.6.2 for package: rubygem-kafo-0.6.11-1.el6.noarch
--> Processing Dependency: rubygem(powerbar) for package: rubygem-kafo-0.6.11-1.el6.noarch
--> Processing Dependency: rubygem(kafo_parsers) for package: rubygem-kafo-0.6.11-1.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: rubygem-kafo-0.6.11-1.el6.noarch
--> Running transaction check
---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
---> Package policycoreutils-python.x86_64 0:2.0.83-24.el6 will be installed
--> Processing Dependency: libsemanage-python >= 2.0.43-4 for package: policycoreutils-python-2.0.83-24.el6.x86_64
--> Processing Dependency: setools-libs-python for package: policycoreutils-python-2.0.83-24.el6.x86_64
--> Processing Dependency: libselinux-python for package: policycoreutils-python-2.0.83-24.el6.x86_64
---> Package ruby.x86_64 0:1.8.7.374-4.el6_6 will be installed
---> Package rubygem-awesome_print.noarch 0:1.0.2-10.el6 will be installed
---> Package rubygem-clamp.noarch 0:1.0.0-1.el6 will be installed
---> Package rubygem-json.x86_64 0:1.4.6-1.el6 will be installed
---> Package rubygem-kafo.noarch 0:0.6.11-1.el6 will be installed
--> Processing Dependency: puppet < 4.0.0 for package: rubygem-kafo-0.6.11-1.el6.noarch
Package puppet-2.7.26-2.el6.noarch is obsoleted by puppet-agent-1.2.2-1.el6.x86_64 which is already installed
---> Package rubygem-kafo_parsers.noarch 0:0.0.5-1.el6 will be installed
--> Processing Dependency: rubygem(rdoc) for package: rubygem-kafo_parsers-0.0.5-1.el6.noarch
---> Package rubygem-logging.noarch 0:1.8.2-1.el6 will be installed
--> Processing Dependency: rubygem(multi_json) >= 1.8.4 for package: rubygem-logging-1.8.2-1.el6.noarch
--> Processing Dependency: rubygem(little-plugger) >= 1.1.3 for package: rubygem-logging-1.8.2-1.el6.noarch
---> Package rubygem-oauth.noarch 0:0.4.7-6.el6 will be installed
---> Package rubygem-powerbar.noarch 0:1.0.11-8.el6 will be installed
--> Processing Dependency: rubygem(ansi) < 1.5.0 for package: rubygem-powerbar-1.0.11-8.el6.noarch
--> Processing Dependency: rubygem(hashie) >= 1.1.0 for package: rubygem-powerbar-1.0.11-8.el6.noarch
--> Processing Dependency: rubygem(ansi) >= 1.4.0 for package: rubygem-powerbar-1.0.11-8.el6.noarch
---> Package rubygem-rest-client.noarch 0:1.6.7-2.el6 will be installed
--> Processing Dependency: rubygem(mime-types) >= 1.16 for package: rubygem-rest-client-1.6.7-2.el6.noarch
--> Processing Dependency: rubygem(netrc) for package: rubygem-rest-client-1.6.7-2.el6.noarch
---> Package rubygems.noarch 0:1.3.7-5.el6 will be installed
--> Processing Dependency: ruby-rdoc for package: rubygems-1.3.7-5.el6.noarch
--> Running transaction check
---> Package libselinux-python.x86_64 0:2.0.94-5.8.el6 will be installed
---> Package libsemanage-python.x86_64 0:2.0.43-5.1.el6 will be installed
---> Package ruby-rdoc.x86_64 0:1.8.7.374-4.el6_6 will be installed
--> Processing Dependency: ruby-irb = 1.8.7.374-4.el6_6 for package: ruby-rdoc-1.8.7.374-4.el6_6.x86_64
---> Package rubygem-ansi.noarch 0:1.4.3-2.el6 will be installed
---> Package rubygem-hashie.noarch 0:2.0.5-1.el6 will be installed
---> Package rubygem-kafo.noarch 0:0.6.11-1.el6 will be installed
--> Processing Dependency: puppet < 4.0.0 for package: rubygem-kafo-0.6.11-1.el6.noarch
Package puppet-2.7.26-2.el6.noarch is obsoleted by puppet-agent-1.2.2-1.el6.x86_64 which is already installed
---> Package rubygem-little-plugger.noarch 0:1.1.3-18.el6 will be installed
---> Package rubygem-mime-types.noarch 0:1.16-3.el6 will be installed
---> Package rubygem-multi_json.noarch 0:1.10.1-1.el6 will be installed
---> Package rubygem-netrc.noarch 0:0.7.7-5.el6 will be installed
---> Package rubygem-rdoc.x86_64 0:3.12-12.el6 will be installed
---> Package setools-libs-python.x86_64 0:3.3.7-4.el6 will be installed
--> Processing Dependency: setools-libs = 3.3.7-4.el6 for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libsefs.so.4(VERS_4.0)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libseaudit.so.4(VERS_4.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libseaudit.so.4(VERS_4.1)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.3)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libpoldiff.so.1(VERS_1.3)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libpoldiff.so.1(VERS_1.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.1)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libsefs.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libseaudit.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libpoldiff.so.1()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libapol.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Running transaction check
---> Package ruby-irb.x86_64 0:1.8.7.374-4.el6_6 will be installed
---> Package rubygem-kafo.noarch 0:0.6.11-1.el6 will be installed
--> Processing Dependency: puppet < 4.0.0 for package: rubygem-kafo-0.6.11-1.el6.noarch
Package puppet-2.7.26-2.el6.noarch is obsoleted by puppet-agent-1.2.2-1.el6.x86_64 which is already installed
---> Package setools-libs.x86_64 0:3.3.7-4.el6 will be installed
--> Finished Dependency Resolution
Error: Package: rubygem-kafo-0.6.11-1.el6.noarch (foreman)
           Requires: puppet < 4.0.0
           Installed: puppet-agent-1.2.2-1.el6.x86_64 (@puppetlabs-pc1)
               puppet >= 4.0.0-1.el6
           Available: puppet-2.7.26-2.el6.noarch (epel)
               puppet = 2.7.26-2.el6
           Available: puppet-agent-1.0.0-1.el6.x86_64 (puppetlabs-pc1)
               puppet >= 4.0.0-1.el6
           Available: puppet-agent-1.0.1-1.el6.x86_64 (puppetlabs-pc1)
               puppet >= 4.0.0-1.el6
           Available: puppet-agent-1.1.0-1.el6.x86_64 (puppetlabs-pc1)
               puppet >= 4.0.0-1.el6
           Available: puppet-agent-1.1.1-1.el6.x86_64 (puppetlabs-pc1)
               puppet >= 4.0.0-1.el6
           Available: puppet-agent-1.2.0-1.el6.x86_64 (puppetlabs-pc1)
               puppet >= 4.0.0-1.el6
           Available: puppet-agent-1.2.1-1.el6.x86_64 (puppetlabs-pc1)
               puppet >= 4.0.0-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@dev5-puppet01 ~]# 

Running the command with "--skip-broken" didn't help.

Edit #1:

[root@dev5-puppet01 ~]# rpm -qa | grep puppet                                                                                                                                                                                          
puppetlabs-release-pc1-0.9.2-1.el6.noarch

What do you think I'm doing wrong?

share|improve this question
    
can you add the output of the following command rpm -qa | grep puppet – Mike Aug 19 '15 at 9:14
    
Thanks for your response, please check my Edit #1. – Itai Ganot Aug 19 '15 at 10:08

Okay, I found the problem.

I was using puppetlabs-release-pc1-el-6 repository instead of the right one which is puppetlabs-release-el-6.

The release packages were taken from: https://yum.puppetlabs.com/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.