Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Windows PC can connect without problems to a Windows Server 2008 VPN at my office. Everything works.

I set up the same VPN in my Mac with Snow Leopard. It connects, but I can't access any remote computer inside office's VPN.

I have played with some VPN settings, but without success.


share|improve this question
Did you find a solution? – sparks Dec 21 '09 at 17:26
Oh yes, please let's restart it. I tried to connect a MacBook Air to a MS VPN without success. The connection should be authenticated with certificates. I had success with Cisco VPN, but that is about to be replaced with the MS VPN. So, what do I need therefore? Can it be done with the MacOSX built in VPN client (preferred), or do I need a software like IPSecuritas? Which information do I need to enter? It is a very large MS network (AD, Kerberos) what should be connected to. I am Mac related, left-handed with MS. ;-) – user72179 Feb 25 '11 at 12:00
  • already tried to use the IP address of the server?
  • double checked routing settings on your mac?
  • tried to check the "send all traffic over VNP"
  • remote IP address range conflicts with the local one? (routing problems again)
share|improve this answer
* IP doesn't work. * How can I check the routing settings on my mac? I'm very new to mac world. * Tried, but didn't help. – Erick Sasse Oct 16 '09 at 0:50

When VPN'd in from your mac could you run the following commands from a terminal and give us the output:

sudo ifconfig

sudo route

When VPN'd in on your windows machine could you give the output of the following 2 commands and give us the output:

ipconfig /all

route print

Comparing these will show if you have similar routing when connected on each device and ensure that you are getting a correct IP on your mac like you are on your PC. My initial suspicion is that you are not getting a correct default gateway update or route update on your mac like you are on your PC. This was too long to coherently put as a comment.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.