Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a little Exchange/Outlook installation here that fetches the mails from our provider with POP3.

Now to be able to send emails outside our organisation, I added another SMTP address to the Exchange User:

my.boss@ourcompany.com (Default / Reply Address)
boss@company.local

Sending email works using the default address. But now there is an error message each time we start Outlook.

Outlook tries to autodiscover using autodiscover.ourcompany.com which doesn't exist. Our autodiscover files are placed on our local server. I think all the servers are discovers, because everything works as expected. Everything except the error message on each Outlook start. (The error message is actually because of an invalid certificate but I don't see why Outlook should contact an external host at all!)

So how can I solve this? Forcing Autodiscover on every Outlook client to use the local hosts? Or ist there an even better way?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

You could solve this through DNS.

One way is by having an ourcompany.com.local zone defined on your DNS server and setup the appropriate addresses to resolve (ie: autodiscover.ourcompany.com.local) and on your DHCP server set the DNS suffix of .local to be given to your clients.

That way, when the PC goes to look for autodiscover.ourcompany.com, it will first look for autodiscover.ourcompany.com.local and get the address from your local DNS server with the Exchange server's internal IP address.

If a user tries to go to www.ourcompany.com and you haven't defined www.ourcompany.com.local then it will find www.ourcompany.com as it did before.

This way is useful if some of your services are internal and others are not, so you don't want to replace all of the records of ourcompany.com with local addresses.

Another similar way, is to just define ourcompany.com on your local DNS server and configure all of the records appropriately, then you don't have to get into the DHCP/DNS Suffix situation.

share|improve this answer
    
Thanks. I cannot test your solution but it sounds reasonable and straightforward! –  Tarnschaf May 11 '10 at 11:17
add comment

If all your workstations are joined to the domain, which I presume they are if you are wanting to use a .local address for auto discover, then you can set the auto discover URL using Service Connection Point (SCP). This article explains the 4 methods of getting auto discover to work, with explanations on how to do it, the SCP instructions are first.

share|improve this answer
    
Thanks, I already read this article, maybe I should thy the SCP setting and hope it overrides the clients behaviour: Well, the computers are actually in a workgroup because the domain setting broke file sharing wit non-domain clients.. but they automatically find the Exchange server, I thought this should be enough of auto discovering for mail to work.. –  Tarnschaf Oct 9 '09 at 21:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.