Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The office has a small LAN, composed by a Linksys WRT54G2 sharing a DSL connection, a hub, and several wired and wireless clients. DHCP is enabled in the Linksys.

The DHCP clients table shows the connected machines, some with host name, but I can't ping or otherwise connect to any of them using the hostname. Using the IPs works fine.

From the console I do

nslookup [connected hostname] [linksys IP]
but I get
Server: [my ISP's DNS]
Address: [my ISP's DNS]#53

** server can't find [connected hostname]: NXDOMAIN

Not sure if the Linksys is handling the DNS request redirecting it to the external DNS, or if it's not responding and nslookup is using the external DNS.

In any case, this isn't working, and I don't see anything in the Linksys control panel to enable or disable this feature. This is supposed to just work, right?

share|improve this question

4 Answers 4

up vote 3 down vote accepted

Given the output that you are given here it appears that the Linksys router is handing all DNS requests up to the ISP's DNS server. Linksys routers do not have DNS themselves and don't 'hold' the names of the connected machines locally. Most likely your computers are using NetBIOS broadcasts to identify each other within the network, but there is no 'formal' name-to-IP mapping going on.

If you have the spare box, or an underutilized server one option could be to set up one box as a DNS server, have all your workstations point and register to that server, then have that server redirect to the ISP's DNS. If you cannot get the workstations to work by pointing their DNS requests to the router itself.

share|improve this answer
2  
dhcp hostname to dns is not a feature of any linksys router I know with the stock firmware - I suggest you look into ddwrt which is an aftermarket firmware that does provide that feature. (It also crashes less) –  reconbot Oct 6 '09 at 18:27
    
I'm afraid I don't know much about Linksys firmware, I use Netgear on my home router, and we use various professional products at work. Thanks for the contribution with your suggestion. –  Laranostz Oct 6 '09 at 18:33

What DNS servers and DNS search suffix are getting pushed to the clients? Make sure that the router's IP address is the DNS server that the clients are using. Also make sure that you're setting a domain name that can be being given to the clients for their search DNS suffix so that they are all looking for the same fully qualified domain names.

share|improve this answer

Not necessarily - not all DHCP servers will automatically assign hostnames to their clients and register them in DNS, and a brief skim through the WRT54G2 manual doesn't mention it anywhere.

The other problem is that you don't have (or don't mention) anything to handle LAN-side DNS requests - the WRT54G2 doesn't appear to have the ability to handle DNS zones of its own, it just refers everything to your ISP's DNS server, which won't know about your local hostnames.

share|improve this answer

No, this doesn't "just work" on a Linksys, nor on most other SOHO routers.

The name entry that you're seeing in the DHCP table is coming from the individual machines - they supply their own NetBIOS name in the DHCP request.

There's no mechanism to have that name subsequently served by DNS from the router.

By the way, as you're using Linksys the DNS settings that your LAN gets will probably depend on whether your DSL WAN connection was up or not when each PC connects. On most routers when they first boot up they give out their own address to use for DNS and stay that way.

However once the WAN link has synced a minute or so later and obtained real DNS settings from the ISP most Linksys routers then start dishing out those DNS server values instead. This is a good thing - see RFC 5625.

Hence if you want consistent DNS behaviour I'd also recommend deploying your own DHCP server.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.