Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to start an IIS website & I keep getting the error

Unexpected error 0x8ffe2740 occurred

Investigating in the system log displays this error

The service could not bind instance 1. The data is the error code. For additional information specific to this message please visit the Microsoft Online Support site located at: http://www.microsoft.com/contentredirect.asp.

I have had WAMP running on this machine, but I shut it down & I can't see anything else that could be bound to port 80. If I change the port to something else it works fine, so I am assuming it is because something else was bound to 80 and it hasn't been released, but I can't see what it is

share|improve this question

2 Answers 2

Use netstat or ActivePorts to find if something is still holding on to port 80.

share|improve this answer
    
ActivePorts says there's nothing on Port 80 –  Glenn Slaven May 12 '09 at 1:20
    
What OS is this? –  squillman May 12 '09 at 1:44
    
It's Windows XP SP2 –  Glenn Slaven May 12 '09 at 1:58
    
Do you have Skype or anything like that running on it? –  squillman May 12 '09 at 2:01
    
I'm not familiar with ActivePorts, but make sure it checks on both the public and the loopback interface. –  Ivan May 12 '09 at 2:06

I once had a problem with Skype listening to port 80, if it was started while IIS was not. If Skype is taking over port 80, you can solve this problem changing a Skype setting:

File > Options > Connection

Uncheck "Use Port 80 and 443 as alternatives for incoming connections." You should be able to restart default website now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.