Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have my primary router running ubuntu, which has been working fine for my basically very tiny large-scale setup (if that makes any sense at all). I got a handful of extra soho routers which I decided I would setup near a couple of wired workstations and configure them to extend the wireless network.

Note in advance: security is not paramount. WEP is sufficient for my purposes.

I set up all the soho routers to use the same ssid and security settings as the main router, and turned off the DHCP server option on all of them, plugged them in and everything seemed to work exactly as expected. So I got back on my laptop and walked into the room where the main router is and the connection "dropped" (laptop is running Windows XP).

The issue: on the main router, I have dhcp configured so wireless users are in 192.168.3.0/24 and wired are in 192.168.2.0/24 . Since all the soho routers are "wired", wireless clients connecting through those AP's get a "wired" IP. When the client moves to the range of the main router, it needs a new IP, thus breaking the connection for 10 seconds or so as Windows goes through the dhcp process again.

How do I go about configuring the wireless and wired devices on my main router to use the same dhcp range?

dhcdp.conf

subnet 192.168.2.0 netmask 255.255.255.0 {
        min-lease-time 360;
        default-lease-time 86400;
        max-lease-time 604800;
        range 192.168.2.10 192.168.2.200;
        option routers 192.168.2.1;
        option domain-name-servers 192.168.0.1;
        authoritative;
        }

subnet 192.168.3.0 netmask 255.255.255.0 {
    min-lease-time 360;
    default-lease-time 86400;
    max-lease-time 604800;
    range 192.168.3.10 192.168.3.200;
    option routers 192.168.3.1;
    option domain-name-servers 192.168.0.1;
    authoritative;
    }

/etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback

# WAN connection
auto eth1
iface eth1 inet dhcp

# LAN connection
iface eth2 inet static
        address 192.168.2.1
        netmask 255.255.255.0

# WLAN connection
auto ath0
iface ath0 inet static
        address 192.168.3.1
        netmask 255.255.255.0
        up      iwconfig ath0 mode Master && iwconfig ath0 essid "shadow-ubuntu" && iwconfig ath0 key *********

auto eth2
share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

You need to bridge your eth2 and ath0 interfaces so that the wired and wireless networks become one subnet. I don't know the exact syntax for the ubuntu interfaces file, but you'll remove the address and netmask statements from eth2 and ath0 and add a new iface called br0 that will have one of those IP addresses (e.g., 192.168.2.1) and specify eth2 and ath0 as members of the bridge.

share|improve this answer
1  
Syntax is available here help.ubuntu.com/community/BridgingNetworkInterfaces –  Alex S Oct 7 '09 at 12:21
    
/etc/default/dhcp3-server also needs to be updated to use the bridge device instead of ath0 and eth2 –  Alex S Oct 7 '09 at 16:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.