Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to do a remote execution on a windows host from Linux with winexe. I get the error: ERROR: Failed to install service winexesvc - NT_STATUS_ACCESS_DENIED

The authenticated user should have administrator rights.

What exactly does this error mean and how can I get remote execution working?

share|improve this question
up vote 0 down vote accepted

The error means that the user does not have sufficient rights on the target machine. "Something" went wrong with the administrator rights for that user... Is it a Domain setup or standalone? Could you paste the winexe command line you are using (without password and/or public IP)?

share|improve this answer
I played around with another machine where I have multiple user accounts; here administrator works but other users do not. What are exactly the needed rights? – housemaister Oct 7 '09 at 10:01
I believe that you need to have Admin rights to add a service to a computer. – mrdenny Oct 7 '09 at 15:54
Correct, admin rights are necessary besides some other requirements. While trying and playing around the rights got mixed up; in the described scenario, I belive, the user did not have admin rights. I found a complete list of requirements at the winexe webpage: – housemaister Oct 8 '09 at 11:37

This fixed the error I encountered with winexe when we upgraded from Windows XP (worked) to Windows 7 (did not work):

They mention Windows Vista specifically, but it works equally well for Windows 7.

share|improve this answer


More info here:

Implement the LocalAccountTokenFilterPolicy registry key, as described in the KB article, and that should resolve your issue. Or you can turn off UAC, but that's not recommended.

share|improve this answer

The problem in my case was the service winexesvc was not started. By default it's been configured to start manually hence after reboot we need to start it manually or change the service properties to start it automatically.

share|improve this answer
this solved the problem to me, after looking for quite a while! – Oz123 Nov 2 '12 at 19:13

The command syntax should be :- winexe -W WORKGROUP -n netbios-name -U user%pass //remote_pc_ip_address 'cmd.exe'

username should be valid user name and not the account logon name.

also check : turn on file and printer sharing turn off windows firewall disable User account settings enable NetBios over IP . from Ipv4 properties advanced settings. Also check," net share " command output , here you can check admin share is enabled or not Admin share (ADMIN$) is most important part to be enabled to run winexe .

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.