Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I run Apache HTTPD 2.2 on my FreeBSD 7.2 webserver. I have enabled the httpready and dataready in my /boot/loader.conf, like this:

accf_http_load="YES"
accf_data_load="YES"

That works great when the server is started, but whenever I restart (via apachectl graceful or apachectl restart), I get a salvo like this in my /var/log/httpd-error.log:

[Thu Oct 08 13:32:53 2009] [warn] (22)Invalid argument: Failed to enable the 'httpready' Accept Filter
[Thu Oct 08 13:32:53 2009] [warn] (22)Invalid argument: Failed to enable the 'dataready' Accept Filter
[Thu Oct 08 13:32:53 2009] [warn] (22)Invalid argument: Failed to enable the 'httpready' Accept Filter
[Thu Oct 08 13:32:53 2009] [warn] (22)Invalid argument: Failed to enable the 'dataready' Accept Filter
[Thu Oct 08 13:32:53 2009] [warn] (22)Invalid argument: Failed to enable the 'httpready' Accept Filter
[Thu Oct 08 13:32:53 2009] [warn] (22)Invalid argument: Failed to enable the 'httpready' Accept Filter

There' is a bug for this on ASF bugzilla, but that doesn't look like it's going anywhere soon, so in the meantime, I'm looking to find out if this is really a problem (does the httpready filter still work despite the warnings?), and if it is, is there a workaround?

share|improve this question
    
Note that this is similar to serverfault.com/questions/68120/… but has more specifics. Thus the new question. –  mikl Oct 8 '09 at 11:53
    
Did you check via kldstat to make sure something really crazy didn't happen to the module? Also did you try restarting Apache from the rc script (/usr/local/etc/rc.d/apache22 restart)? –  Chris S Jan 17 '12 at 1:13

3 Answers 3

up vote 1 down vote accepted

I believe it's one of two things. Either Apache doesn't close the previous connection before opening the new listening socket (or it might even recycle the old) or the Kernel associates filter use with a PID instead of a socket (which would be weird at best). Definitely something not right but I'm not sure if it's in Apache or the Kernel. The problem still exists in 9.0 and 2.2.20.

Since nobody seems to have bothered with this in 2 years and it's easily worked around by using the rc script instead of apachectl, I'm not going to hunt it down (sorry).

share|improve this answer
    
Thanks for the insight. I switched to nginx a year ago, so it does not really matter to me either :) –  mikl Jan 18 '12 at 19:54

You don't want to use the httpready filter on FreeBSD at this time anyway. I recommend disabling it entirely.

share|improve this answer
1  
On what do you base this recommendation? –  voretaq7 Sep 13 '11 at 16:16

Just open shell prompt and type the following command to load accf_http under FreeBSD :

# kldload accf_http Restart apache:

# /usr/local/etc/rc.d/apache22 restart Update /boot/loader.conf file

Type the following command so that driver get loaded at the time of booting system:

# echo 'accf_http_load="YES"' >> /boot/loader.conf

http://www.cyberciti.biz/faq/failed-to-enable-the-httpready-accept-filter/

share|improve this answer
1  
If you had actually read my question, you'd find that I already have the mentioned line in /boot/loader.conf. –  mikl Oct 11 '11 at 14:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.