Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to send an SNMP trap from Windows XP using snmptrap.exe from the Net-SNMP package net-snmp-5.4.2-1.win32. Snmptrap is in the path. This command-line works fine on two boxes, but not from my XP workstation:

C:\>snmptrap -v1 -cpublic [manager IP] 1.3.6.1.4.1.19746.2 127.0.0.1 6 13 0 1.3.6.1.4.1.19746.1.6.1.1.1.5 s "IGNORE ME"

On the systems where this works, the trap is sent almost immediately and control returns to the prompt within 1-2 seconds. On my XP workstation, I see a long pause (5-10 sec), and no trap is sent. I'm watching the wire with Wireshark and no packets are sent. I can ping the SNMP manager system and see that in Wireshark. I can also netcat to port 162 and send across a dummy packet, and that shows up in Wireshark, so I think I've ruled out causes external to snmptrap. I have tried other similar commands to the above using different OIDs and varbinds, all have the same result (on this system).

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Ahem. %path% fail! Windows comes with a binary called snmptrap...Who knew?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.