Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having an issue with my sqlservr.exe which is always reading the SBSMonitoring.mdf, around 50MB/sec. I saw that in Reliability and Performance mmc. I don't think my hard drive love it... and it slows down my server. We have a SBS 2008.

I found nothing about it, help me please :) Thanks.

share|improve this question
    
It's not mysql.exe it's going to be sqlservr.exe. MySQL is a totally different product which can't access SQL Server database files. –  mrdenny Oct 8 '09 at 18:24
    
oops yeah that's it –  Bastien974 Oct 8 '09 at 19:17
    
Something seems odd here as that's an awful lot of IO for SBS monitoring, what's the disk queue length on the drive? Does the page for sbs monitoring show up at all? –  Jim B Mar 8 '10 at 22:10

3 Answers 3

SBS Monitoring looks like a beast. I've found two links for you to look at:

I hope these help. You might want to look at either turning this off, or configuring it to use fewer resources. 50MB/s sounds like your drive is exclusively doing this monitoring.

EDIT: Here's another link. This may be more useful:

http://technet.microsoft.com/en-us/library/cc708152(WS.10).aspx

share|improve this answer
1  
I must add that I steer clear of SBS altogether. Whomever thought it was a good idea should be shot. Exchange needs its own box, period. –  user3914 Oct 8 '09 at 15:10
    
Thx but I didn't find anything usefull :( –  Bastien974 Oct 8 '09 at 17:13
    
That's why the new SBS lets you use 2 or 3 servers to host everything. They are finely getting closer. –  mrdenny Oct 8 '09 at 18:23
2  
@mrdenny: When a marketing department specs a technical solution, it's going to end in tears. –  user3914 Oct 8 '09 at 19:30
2  
@Ransolph I've vented to a few people at Microsoft about that issue on a few products. They all agree, but are overruled, by Marketing people. –  mrdenny Oct 9 '09 at 1:18

I had the same issue and posted to Microsoft's SBS Community forum. I was directed to Microsoft Knowledge Base article 981939 which seems to have fixed my problem without disabling the monitoring.

The article includes a powershell script to reduce the amount of monitoring data that is kept from 90 days to 30 days and adds some indexes and statistics to the database.

share|improve this answer

If you aren't using the monitoring disable it. It sounds like you are monitoring a ton of stuff. You can also check the database in SQL Server and make sure that it's not set to autoclose the database which would add to the problem.

share|improve this answer
    
I don't really know how to disable the monitoring thing, how can I choose exactly what to monitor ? –  Bastien974 Oct 8 '09 at 19:19
    
@Bastien: I've edited my original answer with a link to Technet. That looks like it may help. –  user3914 Oct 8 '09 at 19:33
    
@Randolph that looks like it should do the trick. –  mrdenny Oct 9 '09 at 1:17
    
It just shows how to monitor the server, Reliability and Performance mmc in SBS 08 do it all for me. I saw that problem thanks to it, but how to resolve it ? :( –  Bastien974 Oct 9 '09 at 14:07
    
I don't have SBS so I'm going off what I can find (which isn't much at the moment). Is there any way to remove some metrics from the monitor? –  mrdenny Oct 9 '09 at 18:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.