Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I did not install or configure SharePoint on this box but it is in a domain. After creating a web application and site collection, I can not add domain users to the site collection. The OS is AD aware, and I tested this by creating a local group and adding a domain user into that group.

How can I ensure that SharePoint is aware of the domain?

Windows Server 2008/MOSS 2007

share|improve this question
add comment

2 Answers

In Central Administration, you need to go into the Application Management. Once there, look for Authentication Providers, under Application Security. You should have a Default zone, open that and you will be able to pick your authentication type.

share|improve this answer
    
Currently the site is set to: Authentication Type: Windows; Intergrated Windows Authentication: checked; NTLM: Checked; Enable Client Intergration: Yes; With those settings, all should be well. Unfortunately its not. –  adaptive Oct 8 '09 at 19:12
    
Have you added users to the site itself? When you are in the web app, go to site settings, then look under advanced permissions. Try adding a test user there. –  DanBig Oct 8 '09 at 19:27
    
That is what I mean when I say "I can not add users to the site collection" –  adaptive Oct 8 '09 at 19:51
    
This answer is incorret because without an authentication provider set up deverop wouldn't be able to access the site collection in the first place. –  axk Oct 8 '09 at 20:16
add comment
up vote 2 down vote accepted

I think I figured out the solution to my own problem. The SharePoint site collection was running in an application pool with local credentials instead of domain credentials.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.