Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Even when running httpd as root, I get this error:

Starting httpd: (13)Permission denied: make_sock: could not bind to address [::]:100
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:100
no listening sockets available, shutting down
Unable to open logs

I tried changing the ports, even to ones not blocked by iptables and I still get the same error (according to "netstat -an"). Reinstalled and same deal. I'm running CentOS 5.3 x86_64.

Nginx is running on my port 80. I just want to run Apache as a backend so I can view AWStats online. A solution to either this or the above problem would be awesome.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

This sounds like it could be a case of SELinux getting in the way. You should be able to check if it is running by running "/usr/sbin/getenforce". If it says "Enforcing", you could try disabling it by running "sudo /usr/sbin/setforce 0" then restart apache and see if you get the same results.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.