Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running SQL server 2008 developer edition on windows vista home premium. I created a reporting services project that was built successfully in BIDS. When I try to deploy it it gives the following error:

Error rsAccessDenied : The permissions granted to user 'COMP\MYSELF' are insufficient for performing this operation.

The MYSELF account is the only account on the system. It has administrator rights. The reporting service is running with the LocalSystem service account.

If I log in with the MYSELF account into reportmanager, I cannot see the site settings tab. Without the site settings tab, how do I add or change the roles for MYSELF account.

In summary, please help me to open the reportmanager in the browser with the site settings link so that I can change the role of the user account.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I found the answer.

I had to log into the system with the built in administrator account and then add the current user account to the administrator role in the Reporting services manager.

Note that built in administrator account is different from an account which is part of administrators group.

share|improve this answer

To elaborate on rboorgapally's answer...

  1. On Windows 7, click on the Start button and then right-click on Computer
  2. Click on Manage
  3. Expand Local Users and Groups in the left panel
  4. Click on the Users folder
  5. Right-click on Administrator in the center panel
  6. Click on Properties
  7. Uncheck "Account is disabled" then click OK
  8. With Administrator still selected, click on More Actions in the right panel
  9. Select Set Password and provide a password

You can now log in to http://localhost/Reports as Administrator. Now set yourself as a System Administrator for Reporting Services by clicking on Site Settings in the upper-right hand section of the page and clicking on Role Assignment.

Finally, click on Home. Click on Folder Settings and set yourself as a Content Manager.

You may now disable Administrator and use your account to administer Reporting Services.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.