Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I noted recently that Windows Powershell v1.0 is installed on Windows 7 RTM, so I need to install Powershell v2.0 CTP 3 but I can't find it on "Uninstall Programs" and also tried on "Turn on/off Windows Features", How can I achieve this?


share|improve this question
Have you tried just installing v2.0? Stupid question I know, but it might just install on top of v1.0 or uninstall it first. – ChrisF Oct 11 '09 at 16:39
Great question. I also was fooled by the stupid folder name, and because I assumed 2.0 would have intellisense. – Luke Puplett Dec 16 '10 at 18:04
up vote 2 down vote accepted

Althouth the folder is the same, it is Powershell v2 you have on your Win7. You can confirm this by running this command from inside powershell: $PSVersionTable

on my (win7) workstation it reads:

> CLRVersion                    
> 2.0.50727.4927                                                                           BuildVersion                  
> 6.1.7600.16385                                                                           PSVersion                      2.0    
> WSManStackVersion              2.0    
> PSCompatibleVersions           {1.0,
> 2.0}                                                                               SerializationVersion 
> PSRemotingProtocolVersion      2.1

Where "PSVersion" is the giveaway :-)

share|improve this answer

Windows 7 ships with PowerShell 2.0; why do you think it's running 1.0?

See here:

Windows® 7 includes Windows PowerShell 2.0.

share|improve this answer
I dont have the get-diagpack cmdlet used on PDC2008 with Powershell v2 – Angel Escobedo Oct 11 '09 at 16:39
and also I found a folder with v1.0 : "C:\WINDOWS\system32\WindowsPowerShell\v1.0" – Angel Escobedo Oct 11 '09 at 16:40
It's 2.0. Have a look at the link. – Massimo Oct 11 '09 at 17:41

Not sure about Win7, but in XP you had to check the Show Updates checkbox in Add/Remove programs and in Vista you have to click the Show Installed Updates link in Programs and Features to see Powershell and be able to uninstall it.

share|improve this answer
I tryed that, the update packs are not equals, Thanks anyway – Angel Escobedo Oct 11 '09 at 16:53

As already indicated, Windows 7 comes with PowerShell v2. Yes, it can appear that this is v1 because of the folder mentioned here and that scripts are "ps1", but trust me, it is v2.

Now, your comment about get-diagpack... Don't solely base yourself on content from Fall 2008 (@ PDC). Things could have changed several times since then.

If you want to check out the new diagnostics: PS>cd $pshome\modules PS>import-module .\PSDiagnostics PS>get-command -pssnapin psdiagnostics

I've not checked, but you likely won't see anything allowing you to uninstall PowerShell. It is basically considered part of the core OS now. Just like you can't (still) remove command.exe....

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.