Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

1) I have a Windows Server 2008 Standard SP2 2) I am running Hyper-V and have the OpenVPN Appliance Server virtual running 3) I have configured it as it said, only issue was that the legacy network adapter does not have a setting the instructions mention "Enable spoofing of MAC Addresses". My understand is that before R2, this was on by default. 4) Server is running, web interfaces look good 5) I am trying to connect from a Vista 64 box and cannot

5a) If I set to UPD I am stuck at Authorizing and client log looks like:

10/11/09 15:00:42:  INFO:  OvpnConfig: connect...
10/11/09 15:00:42:  INFO:  Gui listen socket at 34567
10/11/09 15:00:42:  INFO:  sending start command to instantiator...
10/11/09 15:00:42:  INFO:  start 34567 ?C:\Users\Peter\AppData\Roaming\OpenVPNTech\config?02369512D0C82A04B88093022DA0226202218022A902264022AE022B?
10/11/09 15:00:42:  INFO:  Got line from MI->>INFO:OpenVPN Management Interface Version 1 -- type 'help' for more info
10/11/09 15:00:42:  INFO:  Got line from MI->>HOLD:Waiting for hold release
10/11/09 15:00:43:  INFO:  Got line from MI->SUCCESS: real-time state notification set to ON
10/11/09 15:00:43:  INFO:  Got line from MI->SUCCESS: bytecount interval changed
10/11/09 15:00:43:  INFO:  Got line from MI->SUCCESS: hold flag set to OFF
10/11/09 15:00:43:  INFO:  Got line from MI->SUCCESS: hold release succeeded
10/11/09 15:00:43:  INFO:  Got line from MI->>PASSWORD:Need 'Auth' username/password
10/11/09 15:00:43:  INFO:  Processing PASSWORD.
10/11/09 15:00:43:  INFO:  OvpnClient: setting need auth to true.
10/11/09 15:00:43:  INFO:  OvpnConfig: Setting need auth to true.
10/11/09 15:00:43:  INFO:  Got auth request from active_config from 0
10/11/09 15:00:47:  INFO:  Sending Credentials....
10/11/09 15:00:47:  INFO:  Sending 25 bytes for username.
10/11/09 15:00:47:  INFO:  Sent 25 bytes for username.
10/11/09 15:00:47:  INFO:  Sending 30 bytes for password.
10/11/09 15:00:47:  INFO:  Sent 30 bytes for password.
10/11/09 15:00:48:  INFO:  Got line from MI->SUCCESS: 'Auth' username entered, but not yet verified
10/11/09 15:00:48:  INFO:  Got line from MI->SUCCESS: 'Auth' password entered, but not yet verified
10/11/09 15:00:48:  INFO:  Got line from MI->>STATE:1255287647,WAIT,,,
10/11/09 15:00:48:  INFO:  Got line from MI->>BYTECOUNT:0,42
10/11/09 15:00:48:  INFO:  Got line from MI->>BYTECOUNT:54,42
10/11/09 15:00:48:  INFO:  Got line from MI->>STATE:1255287648,AUTH,,,
10/11/09 15:00:50:  INFO:  Got line from MI->>BYTECOUNT:2560,2868
10/11/09 15:00:52:  INFO:  Got line from MI->>BYTECOUNT:2560,3378

5b) I setup server for tcp and try to connect, I get a loop of authorizing and reconnecting. Log looks like:

10/11/09 15:00:42:  INFO:  Got line from MI->>HOLD:Waiting for hold release
10/11/09 15:00:43:  INFO:  Got line from MI->SUCCESS: real-time state notification set to ON
10/11/09 15:00:43:  INFO:  Got line from MI->SUCCESS: bytecount interval changed
10/11/09 15:00:43:  INFO:  Got line from MI->SUCCESS: hold flag set to OFF
10/11/09 15:00:43:  INFO:  Got line from MI->SUCCESS: hold release succeeded
10/11/09 15:00:43:  INFO:  Got line from MI->>PASSWORD:Need 'Auth' username/password
10/11/09 15:00:43:  INFO:  Processing PASSWORD.
10/11/09 15:00:43:  INFO:  OvpnClient: setting need auth to true.
10/11/09 15:00:43:  INFO:  OvpnConfig: Setting need auth to true.
10/11/09 15:00:43:  INFO:  Got auth request from active_config from 0
10/11/09 15:00:47:  INFO:  Sending Credentials....
10/11/09 15:00:47:  INFO:  Sending 25 bytes for username.
10/11/09 15:00:47:  INFO:  Sent 25 bytes for username.
10/11/09 15:00:47:  INFO:  Sending 30 bytes for password.
10/11/09 15:00:47:  INFO:  Sent 30 bytes for password.
10/11/09 15:00:48:  INFO:  Got line from MI->SUCCESS: 'Auth' username entered, but not yet verified
10/11/09 15:00:48:  INFO:  Got line from MI->SUCCESS: 'Auth' password entered, but not yet verified
10/11/09 15:00:48:  INFO:  Got line from MI->>STATE:1255287647,WAIT,,,
10/11/09 15:00:48:  INFO:  Got line from MI->>BYTECOUNT:0,42
10/11/09 15:00:48:  INFO:  Got line from MI->>BYTECOUNT:54,42
10/11/09 15:00:48:  INFO:  Got line from MI->>STATE:1255287648,AUTH,,,
10/11/09 15:00:50:  INFO:  Got line from MI->>BYTECOUNT:2560,2868
10/11/09 15:00:52:  INFO:  Got line from MI->>BYTECOUNT:2560,3378
10/11/09 15:00:54:  INFO:  Got line from MI->>BYTECOUNT:2560,3888
...

Is there anyway to turn on robust logging on the server to understand what is happening? Any ideas on how to hunt this down?

share|improve this question
add comment

1 Answer 1

Resolved by OpenVpn support. Fast and free - who could ask for more.

Since I am not on R2, I had to make my mac address static.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.