Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am running Postgres and Bloomberg in a VM WARE Windows XP Virtual machine on a Snow Leopard Mac (bberg is sadly windows only). Here is the IP Config of the virtual machine:

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . : localdomain
        IP Address. . . . . . . . . . . . : 172.16.179.130
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 172.16.179.2

Unfortunately ping in a terminal on the same mac (outside the virtual machine of course) doesn't see that IP address:

users-imac:~ thomasbrowne$ ping 172.16.179.130
PING 172.16.179.130 (172.16.179.130): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3

Therefore I cannot access the Postgres database from outside the virtual machine. I am running "Share this mac's network connection (NAT)" as the network option for the virtual machine, and the Mac is hooked to the network via wifi, where it gets a dynamic IP address. Anything I should be doing? Thanks in advance for the help.

share|improve this question

1 Answer 1

You can try bridging instead of the NATing interface. Bridging means it will get an IP from the same LAN your mac is on instead of one from VMWare NATed interface.

share|improve this answer
    
Thanks Nikore, but then if I do that although I can ping the VM now, the VM doesn't seem to be able to see external network (cannot visit websites for example). I think has to do with WIFI –  Thomas Browne Oct 11 '09 at 23:28
    
Since you are using Wifi I'm guessing this may be a laptop, make sure the network interface VMWare is binding to is your wireless network interface and not your wired network interface. You should be able to select which you are binding to. –  ManiacZX Jan 8 '10 at 5:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.