Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have recently changed our main fileserver from NetWare on workstation hardware to Windows Server 2003 Enterprise SP2 on actual server hardware. Ever since then we've had an occasional issue where our internal applications that use Crystal Reports can't open the .rpt files on the server. I have finally tracked it down...whenever a particular .rpt file gets a total of 20 locks from all users, then the problem starts. Now we just have to figure out how to fix it.

When a particular report file is called from one of our programs it gets a lock on the server. However, the only way it seems that the lock is released is to close the program itself, not just the report. So these locks keep adding up for each user until there is a total of 20 and everyone starts to get errors. Now everyone has to restart the program to release all of the locks and everything is happy again for a while. This never happened when everything was on the NetWare server, which leads me to believe that it is a Windows issue. But is it Windows not releasing the locks? Is there a way to increase this apparent 20-lock limit we are seeing? Would there be a setting on each workstation (Windows 2000 and XP) that is causing this?

I did find a posting on experts-exchange.com (http://www.experts-exchange.com/Database/Reporting%5F/Crystal%5FReports/Q%5F20624991.html) that says Crystal Reports limits the number of copies of a single report being open at a time to 20, and that the application probably isn't cleaning up after itself properly. But, like I said, we never had this issue with NetWare, but we do now that we are on Windows.

Just looking to see if anyone has any ideas.

Thanks!

share|improve this question
    
Could this be an issue with CALs? –  blank3 Oct 12 '09 at 20:00

3 Answers 3

It sounds like when you were on Netware CR was unable to place the locks so you could have a large number of clients connecting to that report. Now that its running on Windows it's correctly setting the lock.

share|improve this answer
    
That's interesting. So what exactly is setting these locks? Users have hundreds of other read-only files open, but the locks are all at 0. These reports are read-only. Apparently it is a Crystal limit. I haven't gotten a response from our programmers yet...they were going to try something within our programs to see if the locks can be freed there (I would think that's how it should be done). –  Brandon Oct 15 '09 at 17:17

You can try disabling opportunistic locking on the client workstations, as a test. I would not recommend disabling this on the server.

MS KBarticle 296264

share|improve this answer
    
I tried this and there was no change in behavior. I was reading about this before but hadn't tried it yet. I, too, thought that disabling the oplocks on the server probably wasn't a good idea. ;) –  Brandon Oct 15 '09 at 17:13

We see the same issue with Users of ESRI GIS opening a global template. The 21st user is unable to the file within GIS, Execl also, but Notepad still is able to open the file. But Notepad is the only application not putting a lock on the file. Other templates are opend without locking the files. Can we somehow prevent the loc? The share hosting the files is readonly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.