Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to play with Cloudera's Distribution for Hadoop on my EC2 account. For configuring it i'm using THIS tutorial. Everything seems to me fine but when I'm trying to run


I'm getting following error:

max@ubuntu:~/Desktop/cloudera-for-hadoop-on-ec2-py-0.3.0-beta$ ./hadoop-ec2 
/usr/bin/env: python2.5: No such file or directory

I tried to run "which env" got this "/usr/bin/env" and there I have these folders: Python and Python2.6

So, should I rename Python2.6 to Python2.5 or there is another way to change fix this?


share|improve this question
up vote 2 down vote accepted

You just need to install Python 2.5-this SHOULD work-but the best way to find the 2.5 distro is by firing up Aptitude and finding the correct one:

apt-get install python2.5

As root of course.

share|improve this answer
Thanks for "apt-get install python2.5" it works now, thanks – Maksim Oct 13 '09 at 0:05
I agree with Josh, but it is likely that the script will work with Python 2.6, so you could change the shebang line to "#!/usr/bin/env python2.6" or even "#!/usr/bin/env python" – John Paulett Nov 6 '09 at 3:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.