Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have windows 7 and I want to host a site for testing purposes. Now I want to set it up so I can type in my ip address in and it will load up my site. This way I can go to any computer type in my ip and it will load it up.

Now I been able to set up IIS 7 so that it loads the default page when I type in localhost. I also got it to load up my webpage when I type in localhost/MySite but I can't get it to do MyIp/Mysite

It won't load up. I am not sure what I need to do to get it to work.


share|improve this question

migrated from Oct 12 '09 at 23:09

This question came from our site for professional and enthusiast programmers.

up vote 2 down vote accepted

If you haven't done so, you must enable port forwarding in your router so that it may send those requests to the server running on the specified port.

share|improve this answer
I believe iis is using port 80. So do I need to set it up for port 80? – chobo2 Oct 11 '09 at 22:20
I also tried this just down. I went to my router and put 4118 as my port. Then I went to my iis and did binding and put this "http" and port = "4118" and left the rest blank. I then tried to go MyIPAddress:4118/Test but I just get "problem loading Page" error – chobo2 Oct 11 '09 at 22:24
You also need to make sure that you have a static IP (wan) at your router or a good way to figure out what your IP is when it changes. Yes, by default IIS7 binds to port 80 – Chris Thompson Oct 11 '09 at 22:43
I got it working thanks. Seems that windows firewall was blocking my port and did not tell me. I don't know why it did not work on port 80. Maybe it is being blocked too but windows firewall is a bit to crazy looking now and I don't know how to easily find if it is blocked or not. – chobo2 Oct 11 '09 at 23:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.