Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I recently got my hands on a Sun Fire T-2000 server, second hand. I can connect to the ALOM using the serial port, but I cannot connect to it over the network. Here are the settings that I have:

sc> showsc
Advanced Lights Out Manager CMT v1.3.2

parameter                value
---------                -----
if_network               true
if_connection            telnet
if_emailalerts           false
netsc_dhcp               false
sc_escapechars           #.
sc_powerondelay          false
sc_powerstatememory      false
sc_clipasswdecho         true
sc_cliprompt             sc
sc_clitimeout            0
sc_clieventlevel         2
sc_backupuserdata        true
diag_trigger             power-on-reset error-reset
diag_verbosity           normal
diag_level               min
diag_mode                normal
sys_autorunonerror       false
sys_autorestart          reset
sys_eventlevel           2
ser_baudrate             9600
ser_parity               none
ser_stopbits             1
ser_data                 8

With these settings, I cannot connect to the ALOM over the network. I have tried both ssh and telnet and neither one is working. Now before someone says something about the fact that the ALOM should not be connected to a network, or the same network as everything else, this is at my home so I'm not really worried about security of the server. I currently have OpenBSD install on the HD.


I have tried to ping the network port and cannot. I'm beginning to think that the port may be faulty. However, I have a 100mbps full-duplex established on the switch for that port, which doesn't make sense unless the port failed in such a way that frames aren't being sent/received.

I bought this machine because it has a multi-core UltraSPARC processor in it. This will allow me to test out my software on a big endian machine.


I reran the VxDiags from ALOM and posted the result below.

    ALOM BOOTMON v1.3.2
ALOM Build Release: 001
Reset register: 00000000


Dual Port Memory Test, PASSED.

TTY External - Internal Loopback Test
TTY External - Internal Loopback Test, PASSED.

TTYC - Internal Loopback Test
TTYC - Internal Loopback Test, PASSED.

TTYD - Internal Loopback Test
TTYD - Internal Loopback Test, PASSED.

Memory Data Lines Test
Memory Data Lines Test, PASSED.

Memory Address Lines Test
  Slide address bits to test open address lines
  Test for shorted address lines
Memory Address Lines Test, PASSED.

Boot Sector FLASH CRC Test
Boot Sector FLASH CRC Test, PASSED.

Return to Boot Monitor for Handshake
   Status = 00007fff

Returned from Boot Monitor and Handshake

Loading the runtime image... VxWorks running.

Starting Advanced Lights Out Manager CMT v1.3.2

Copyright 2007 Sun Microsystems, Inc.  All rights reserved.
Use is subject to license terms.

Current mode: NORMAL
Attaching network interface lo0... done.
Attaching network interface motfec0.... done.
Booting from Segment 1

SC Alert: SC System booted.

Sun(tm) Advanced Lights Out Manager CMT v1.3.2

Full VxDiag Tests

  Read the TOD Clock:        TUE NOV 24 04:24:21 2015
  Wait, 1 - 3 seconds
  Read the TOD Clock:        TUE NOV 24 04:24:23 2015

  50 BYTE PACKET   - a 0 in field of 1's.
  50 BYTE PACKET   - a 1 in field of 0's.
  900 BYTE PACKET  - pseudo-random data.

Full VxDiag Tests - PASSED

    Status summary  -  Status = 7FFF

       VxDiag    -          -  PASSED
       POST      -          -  PASSED
       LOOPBACK  -          -  PASSED

       I2C       -          -  PASSED
       EPROM     -          -  PASSED
       FRU PROM  -          -  PASSED

       ETHERNET  -          -  PASSED
       MAIN CRC  -          -  PASSED
       BOOT CRC  -          -  PASSED

       TTYD      -          -  PASSED
       TTYC      -          -  PASSED
       MEMORY    -          -  PASSED
       MPC885    -          -  PASSED

Please login:

It looks like all the diagnostics pass, so I don't know what to think.

share|improve this question
Your configuration seems correct, can you ping ? – Fredi Nov 24 at 11:08
Nope. I cannot ping it. – Daniel Rudy Nov 24 at 12:01
Are you on the same subnet? Ah, another check, if i remember correctly (it's been ~6 years from when i used to work on this hardware) you should have a ping command in your ALOM, here's a checklist:… try pinging the gateway from your ALOM in case – Fredi Nov 24 at 12:08
I am on the same subnet. I made sure of that. I can't ping it either, no response. And the ALOM doesn't have a ping command, I checked. – Daniel Rudy Nov 24 at 12:32
Maybe an autonegotiation error or such, can you attach your laptop with the ALOM network port via a cross cable? Then, if using linux check ethtool eth0 (or your interface name) and check for link state. – Fredi Nov 24 at 12:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.