Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Trying to get the equivalent of ulimit -n 20000 on a high load web server, however the /etc/security/limits.conf on ubuntu hardy doesn't seem to stick.

here is what I set in the config file.

root             soft    nofile         20000
root             hard    nofile         20000
www-data             soft    nofile         20000
www-data             hard    nofile         20000

I also tried

*             soft    nofile         20000
*             hard    nofile         20000

after rebooting, when i run ulimit -n on root, or www-data or my regular user i still see the default 1024.

share|improve this question

1 Answer 1

up vote 7 down vote accepted

You may have to uncomment from the different files under /etc/pam.d (cron, su, sudo, sshd, login)

session    required
share|improve this answer
thanks! that worked. – Brandon Helwig Oct 13 '09 at 6:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.