Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have two Grandstream GXP2000 hardphones that power on (the LEDs all come on green), but the display is blank, and the switch doesn't recognize the phones as being connected.

In the past, this has happened, except the phones still responded to the network, so I was able to reboot them using the web interface, and they worked again. Simply unplugging it, and plugging it back in doesn't help. I can't reset it to the factory settings, because the display is blank.

I am fairly certain that the phone is the problem, since I have plugged known good phones into the same power and network connections, and they worked. Likewise, the bad phones connected to known-good power and network don't work.

From what I have read online, it sounds like this might be a common problem, but I thought I'd ask here to see if anyone knows any tricks.

share|improve this question
    
@lexu, why do you think this belongs on SU? This is related to administering a VOIP system. I'm pretty sure that falls under SF jurisdiction, wouldn't you say? –  pkaeding Oct 14 '09 at 3:49
    
Have you tried the suggestion from the linked discussion to plug it in with a power supply rather than using PoE? –  tomjedrz Oct 14 '09 at 4:33
    
Yeah, I am not using PoE at all, and I did try switching it for a known good power supply. –  pkaeding Oct 14 '09 at 4:35

1 Answer 1

up vote 1 down vote accepted

From my experience, the GXP handsets were the worst I've ever used. I found much better results using their ATA converter and a cheap £5 handset.

I had problems with the shocking web interface not loading, phones not registering, NAT issues, STUN issues all sorts.

May seem slightly ostentatious but I'd replace them all for SPA941 or 942. You'll have much more fun using them than trying to keep them online :)

share|improve this answer
    
Yup, I ended up replacing them. –  pkaeding Apr 13 '12 at 5:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.