Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

It seems that drive letters may change during unattended XP install.
I'm trying to install XP on a PC with 1 primary partition an 1 logical volume on the hard drive, and 1 CD drive.

After the install I expected to get (as usual):
- C: = Primary partition
- D: = Extended partition
- E: = CDROM

But what I got instead was:
- C: = Ext
- D: = CDR
- E: = Pri

And from all the files that were supposed to be on C:, some are actually on C: (not much) and the rest are on E: (including "program files", "document and setting", ...)
So the install doesn't work, since it's unattended. It expects some files to be in some places but doesn't find them. BTW : This install works just fine on many other PCs.

Where does that come from? Is there any way to fix it?

share|improve this question

2 Answers 2

I've never switched the drive letter of the primary partition. But you can give it a try.

Right Click on My Computer
Select "Manage"
Select "Disk Management"
Right click on the drive you want to change the letter on
Select "Change Drive Letter and Path"
Follow the dialog

I know this will work for you extended partition and CDROM, but I am not too sure about your primary. It might break something.

I would also like to add: you should verify that your answers file (in your unattended install) is correctly configured. While the above method works. The whole idea of an unattended install is ... to tend to something else.

Mop the floor, but don't forget to fix the leaky pipe.

share|improve this answer
    
Yeah...be REALLY REALLY wary of moving the driveletter for the primary partition if Windows is booting. I did it via the registry and it created a terrible mess. Make backups first! –  Bart Silverstrim Oct 14 '09 at 14:01

Is the drive the first drive in the system? I have had trouble in the past with the drive being on the second IDE cable or a slave. If it's SATA make sure it's drive 0.

share|improve this answer
    
In the BIOS look for "Primary-Master" or "SATA-0". –  Chris Nava Oct 14 '09 at 16:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.