Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Do I have to restart something?

Edit: sudo apt-get update has no effect.

When I search this on another machine with the SAME sources.list, it works. But, it still doesn't work on this machine.

sudo aptitude search sun-java6-jdk
share|improve this question

3 Answers 3

up vote 6 down vote accepted

Maybe you forgot to run "apt-get update"...

share|improve this answer
    
That still doesn't work. –  Alex Oct 14 '09 at 20:09
    
What did you add to /etc/apt/sources.list? –  Michael Pobega Oct 14 '09 at 21:06

After editing any configuration files in /etc/apt, you generally need to do an update;

apt-get update

This allows apt to update itself, it's configuration and the server(s) it queries for packages.

share|improve this answer

You might want to double check that you've got the multiverse repository included. The sun packages are in that one. For example, if you've got:

deb http://www.gtlib.gatech.edu/pub/ubuntu/ jaunty main restricted

you can tack on multiverse to the end to add it.

deb http://www.gtlib.gatech.edu/pub/ubuntu/ jaunty main restricted multiverse

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.