Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to mount a samba share using smbfs as root (on ubuntu-server), but every time I mount it it's mounted as root:dialout

Here is the fstab entry (line breaks added for presentation)

//192.168.1.68/mount_name /root/mount_point smbfs ¬
auto,username=user,password=pass,uid=root,umask=000,user,defaults 0 2

How can I make it mount as the root group?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

Add the gid=root option to the options. Also, use the cifs client rather than smbfs, as that is more modern.

share|improve this answer
add comment

//192.168.1.68/mount_name /root/mount_point smbfs ¬ auto,username=user,password=pass,uid=root,gid=root,umask=000,user,defaults 0 2

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.