Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Three days ago I put online new portal that comes with csm I made myself. Problem that occurred is following: Administrator logs to cms, publishes few news and then he can't access portal at all (whole domain is not accessible to him). Then he tried to access it via mobile phone and he made... but only for few minutes, because after publishing few news he couldn't access domain again. This happened 3 days when portal was launched. Then after hour-two of waiting domain is accessible and then again same problem... I thought it could be some physical problem because it was stormy that night, so I was comforting myself. But problem started repeating the day after and yesterday, when he restarted his router and then immediately the domain became accessible. Again, he published few news and then again he was blocked. Restarting router (to get new ip) resolved the problem. What I don't understand is how comes that I'm not blocked because I tried to do all things he did in CMS but it didn't affect me. Is there possibility that his IP was blocked by server because of some errors I made while programming this CMS. I used "a lot" of jquery (ajax) and php. Thanks in advance for answering.

UPDATE:
Couldn't put this in comment so I use answer: @ Dennis: I found this error_log in cpanel: http://www.sinj.com.hr/error_cpanel.txt... When accessing via Firefox this is error (original is in Croatian so I'll try to translate): Litteraly translated, first sentence is this: "Link is broken", but I think software is not translated good and it shoul be probably "Connection could not be established". - This document doesn't contain any data. This page is temporary not available or too busy. Try again in few moments. If you can't load any page please check you network settings. If you computer is protected with firewall or proxy, check if Firefox has permission to access Internet.

He tried using Firefox and Internet Explorer. It was tested on 2 computers that share one connection to internet. Mobile phone uses it's own connection to internet. I haven't tried anything because I don't know what to try. All I did was simulating actions he did, but on my computer, but didn't discover anything.

Thank you for trying to help!

share|improve this question
    
What server software? What kind of firewall/security software is on the server? –  Josh Oct 15 '09 at 11:55
    
hmmm... I was just reviewing this portal (sinj.com.hr) and after opening index page i got error: Firefox doesn't know how to open this address because the protocol (vijestihttp) isn't associated with any program. I don't know if I holded any button on keyboard and clicked on something but I've never seen this warning before... –  ile Oct 15 '09 at 12:22
    
Are there any messages in the server logs? When the domain is not accessible, what kind of error messages is the administrator seeing? What is he using to access the site? What else have you tried? As for the protocol error in your comment - how is that related? That problem sounds to me like the characters "vijesti" just got accidentally inserted in the Firefox address bar. I do that kind of fumble-finger or mis-paste all the time. –  Dennis Williamson Oct 15 '09 at 12:55
    
@ Josh: Apache 2.2.11 (Unix). I dont know how to find out what firewall is on server? cPanel Version is 11.24.5-STABLE –  ile Oct 15 '09 at 14:35

1 Answer 1

up vote 0 down vote accepted

SOLVED:

I contacted my hosting provider and they said problem was in mod_sceurity line <(.|n)+> I don't know details but it really solved my problem

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.