Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a w2k3 server (terminal server) and a domain user.

If the user accesses "\\TS\Folder" from another computer, that user can read\write without any problem. If I login to "TS" as the user, they cannot access the folder "\\TS\Folder" using the UNC convention. "C:\Folder" works fine. I even tried adding the user to the admin group of TS and it still did not allow access when using the UNC path locally.

I've relogged, rebooted, gpupdate'ed, etc. Any ideas? I cannot think of a reason why the user can access with the UNC path on other computers but not with the UNC path locally.

EDIT: Situations tried:
BadUser on TS to \\TS\Folder = Fail
BadUser on TS to C:\Folder = Pass
BadUser on TS to \\xp1\Folder = Pass
BadUser on xp1 to \\TS\Folder = Pass
BadUser on xp1 to \\xp1\Folder = Pass

share|improve this question
It it just that particular user or does this happen for any user in your domain? – Zoredache Oct 15 '09 at 17:27
Can the user access \\someotherserver\folder while logged on to TS? – nray Oct 15 '09 at 17:43
@Zoredache - Just this user. Other users can access it fine @nray - Yes, I can connect to other shares on other servers – bugtussle Oct 15 '09 at 18:28
Is 'TS' the actual computer name or an alias? – ITGuy24 Oct 15 '09 at 19:08
up vote 2 down vote accepted

Well it turns out I left out an important detail: The folder contains vbs files, it worked when I tired to access a plain text doc or word doc. We also recently updated to ie7. I had to add "file://ts" to the trusted sites list in IE7. It works better now.

Thanks for your help. Hopefully, MS will remove IE dependence one day.

share|improve this answer

You mentioned that you checked the share permissions, but have you checked the folder permissions as well?

share|improve this answer
Yes, I checked both. I can access it from another computer, I cannot access it locally with the UNC path – bugtussle Oct 15 '09 at 15:28
I also added the user to the Local Admin group and it still did not work – bugtussle Oct 15 '09 at 15:30
Have you enabled file and print sharing on your firewall? It's possible that this traffic could be getting blocked. – dasaybz Oct 15 '09 at 18:12
firewall is disabled – bugtussle Oct 15 '09 at 18:25

Anything in the event logs and can you connect to shares on other servers?

Check to see if the Workstation service is having issues.

share|improve this answer
Nothing from the Workstation service in the logs. I have connected to other shares in the network without issue. – bugtussle Oct 15 '09 at 18:24

There was an issue with Windows XP SP1 that would cause this to happen - the problem was related to the loopback interface ( being unable to tell the NetBIOS over TCP requestor the interface speed. This was fixed in one of the post SP1 hotfixes IIRC and I've never heard of it affecting Windows 2003 but they shared a lot of code so it's possible.

Are you seeing Event log entries with ID 3019 when the attempt to map to the UNC path fails?

share|improve this answer
I do have some 3019 events, although it does not always create an event when access is denied. – bugtussle Oct 15 '09 at 18:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.