Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having trouble getting the html login form to work instead of the default pop up authentication login form. This is what I have in my trac.ini for the account-manager and components sections:

[account-manager]
generated_password_length = 8
hash_method = HtDigestHashMethod
password_file = /trac/.htpasswds/passwd
password_format = htpasswd
password_store = HtPasswdStore

[components]
acct_mgr.admin.accountmanageradminpage = enabled
acct_mgr.db.sessionstore - disabled
acct_mgr.pwhash.htdigesthashmethod =disabled
acct_mgr.web_ui.accountmodule = enabled
acct_mgr.web_ui.loginmodule = enabled
acct_mgr.web_ui.registrationmodule = enabled
trac.web.auth.loginmodule = disabled
webadmin.* enabled

Do these settings look correct?

share|improve this question
    
Has anybody encountered this problem before? –  Amy Oct 15 '09 at 15:50
add comment

1 Answer

There are a couple of typos in your [components] section; in particular, you have a - instead of an = on the acct_mgr.db.sessionstore line, and you are missing an equal sign on the webadmin line. Assuming you are using Trac 0.11, webadmin is now part of core, so you shouldn't have to explicitly enable it anyway.

If fixing those things does not solve the problem, be sure to enable logging, restart your webserver, try again, and check the trac.log file for clues.

During US business hours, there's usually someone hanging around #trac on freenode.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.