Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
 ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/         <Directory "/usr/lib/cgi-bin">                 AllowOverride None                 Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch                 Order allow,deny                 Allow from all         </Directory>

so i have a new virtual host set up @ /var/www2

i can access everything fine.

except when i navigate to /cgi-bin/

it throws 403 error.

share|improve this question
    
What are the permissions on the folder /var/www2? –  racyclist Oct 15 '09 at 20:41
    
drwxrwxrwx 8 www-data www-data –  asdfasdf Oct 15 '09 at 21:19
add comment

1 Answer

There could be 2 things going on here. If you are going to yourdomain/cgi-bin/ with nothing else after it, and have directory indexes turned off that is exactly what is supposed to happen without an index.html in the path. It can't show an index, because it doesn't exist, and you don't have permission to browse the contents.

If you are trying to hit a script directly yourdomain/cgi-bin/script.pl and you are getting it, you need to add the execute bit on the scripts in there, and make sure the permissions are set so that the webserver can execute them.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.