Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
 ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/         
<Directory "/usr/lib/cgi-bin">                 
AllowOverride All              
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch                 
Order allow,deny                 
Allow from all         

i get 403.

my permission settings of the /var/www/cgi-bin is

drwxrwxrwx 8 www-data www-data
share|improve this question

You realize that in apache configuration fragement your cgi-bin directory is /usr/lib/cgi-bin, but directory you mention checking the filesystem permissions on is /var/www/cgi-bin? Which directory did you really want? Do you need to update your configuration to point at /var/www/cgi-bin?

I also think that it isn't really that wise to have to have your cgi-bin directory owned/writable by the apache service account. With this setup a buggy cgi script could be used to upload content to be executed by your server.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.