Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am currently developing some applications on my local 'serverfarm'. I have set up ZendServer with Apache2 and PHP, which works very fine, and nothing unwanted happened until now:

Now I wanted to manage my MySQL databases with phpMyAdmin, because Sun's MySQL SQL tool seems to cause problems creating valid batches.

Working with PMA is not the problem, I am extremely used to work with PMA, if I could access it.

And this is my actual problem: My Firefox wants to tell me that he can not open a 'self-signed certificate'. I tried to work-around that by editing Firefox's ssl configurations, but it did NOT seem to work.

Now I have to change the servers' certificates, but I did not where to find the specific file, because I never had to worry about ssl or tls configurations.

share|improve this question

2 Answers 2

When Firefox, or any other browser, has a problem with a certificate (expired, self-signed, invalid domain, etc) there is a dialog where you can add a security exception. You should be able to add a permanent exception for the warning.

If you continue to have issue, why not disable SSL? If it's just local development, what's the risk?

share|improve this answer
    
The problem is, that PMA is only reachable via https:// . This is ZendServer's security standard. –  daemonfire300 Oct 16 '09 at 17:15
    
and by the way, I am sorry, but if I add localhost or any internal ethernet ip to the exceptions firefox still kicks me. –  daemonfire300 Oct 16 '09 at 17:20
    
I'm not suggesting to add it to any exceptions list in the options, but when you actually hit the page. In my firefox (3.0.x on Linux) it says: "Secure Connection Failed The certificate is not trusted because the issuer certificate is unknown. etc.." At the bottom is a blue link "Or you can add an exception..." - Is this what you are doing? –  Kyle Smith Oct 16 '09 at 17:36
    
No, it says: (US) bit.ly/3Be37B (EU) imagr.eu/upload/issuer.png "self-signed etc. etc." –  daemonfire300 Oct 16 '09 at 18:22

This is the correct solution.

I found this solution while cruising through stackoverflow.com

Thank you anyway.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.