Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a massive problem with my network printers - one in particular.

A little background:

Originally, all of our printers were added on our domain controller, and shared. There were around 20 printers. This caused big problems with our domain controller, running out of resources etc. The printers were migrated to a virtual server (using printmig.exe) and this solved the problems.

A couple of days ago, this server blew up, and for reasons unknown, a backup wasn't available.

I've allocated a machine (Windows XP Pro) called it printserver, and added all the printers to it (I found the .cab file of all the printers from the previous migration)

I installed all the required printer drivers, shared the printers etc... and added them to users machines. All is well, except for one printer.

This printer, is a Zebra 2844-z http://www.zebra.com/id/zebra/na/en/index/products/printers/desktop/lp2844z.html

It's connected to a HP JetDirect 175x http://h10010.www1.hp.com/wwpc/us/en/sm/WF05a/18972-18972-236253-34214-64302-28830.html

The ip address is 10.0.9.21

I have installed drivers for both on the xp print server.

However, it simply doesn't work - I can't print to it, print a test page, or anything.

I've done the usual "off and on again" on every bit of related equipment. I thought it may be the printer that may have coincidentally died on the same day as the server failure, so I plugged it directly into my laptop via usb, and printed fine.

I'm all out of ideas with how to fix this, please, anybody that can share any ideas, I'm very grateful

share|improve this question

2 Answers 2

If you're using a Standard TCP/IP port, make sure you can get connectivity to the print server device by using TELNET, whatever name or IP you've got assigned to the Standard TCP/IP port, and the TCP port number assigned to the Standard TCP/IP port.

So, if you've got it on 10.0.9.21 setup for HP direct print on port 9100, do a:

TELNET 10.0.9.21 9100

And see that you get a good TCP connection.

It sounds a bit silly, perhaps, but it's good to know that everything is talking properly from the Windows queuing server to the print server device.

When you say "can't print", can you elaborate-- are jobs sitting in the Windows print queue or are they disappearing from the Windows queue?

share|improve this answer

Ugh, Zebra printers are 2 parts awesome and one part evil. What I found with their drivers is that they want to talk directly to the hardware port on the local machine. That is, the driver specifically interfaces with the USB via the Zebra port that gets setup during the driver install (viewable on the Ports tab of the printer properties). Basically, if the local print driver ain't talking to the Zebra port that gets installed you ain't printin'.

I never had one that had a network card in it, but from my experience this was going to be the only way to get it to talk on the network.

share|improve this answer
    
hmm... this one was working though.... It's plugged into that HP JetDirect thing - nothing had changed in terms of hardware, except the main print server, due to the other one failing. –  alex Oct 17 '09 at 22:44
    
Ok, then the first 2 things I'd check are the port settings on the clients and on the server. –  squillman Oct 18 '09 at 0:18
    
I like the phrase "2 parts awesome and one part evil", especially re: these things. I've a Customer w/ a boatload of them. I consider myself lucky to keep my distance from them. Their on-site software engineer wrote a program (tied to a Windows print queue) to process jobs for the Zebras submitted via VPN by their Customer (potentially hundreds of labels in a single job), break the job into individual labels, and resubmit them to another print queue such that if the printer ran out of paper, etc, the entire job, as submitted, wouldn't reprint. It was insane. I can't believe he pulled it off. –  Evan Anderson Oct 18 '09 at 3:55
    
I've now got a little further with this problem: However: serverfault.com/questions/75650/… –  alex Oct 18 '09 at 13:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.