Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a major problem with our Zebra ZTC LP2844-Z We have the printer plugged into an HP JetDirect 175x, and this has an ip address of 10.0.9.21 I've added the printer to our print server machine, and shared it on the network as "LabelPrinter"

Upon adding the printer to the client pc (LabelPrinter on printserver), i can print a test page, and print a "hello" message using notepad. However, it will not print labels from our Business Post (courier) software The document goes into the print queue, and says it is printed, however it does not.

I've also tried connecting the printer directly via ip address (circumventing the print server pc), and it will not print the label. So it is not a case of missing drivers on the print server pc.

I then tried connecting the printer directly via usb, and it will print the label.

Any idea as to what's going wrong?

This setup was working, however the previous print server failed, and i had to rebuild it from scratch, and re-add the printers to workstations etc...

share|improve this question

3 Answers 3

up vote 2 down vote accepted

We had a similar problem when we added another Zebra, same model as yours, a while back. The IT person from the courier company removed the Zebra supplied printer driver and replaced it with generic text. That might not work for you but may be worth a try.

share|improve this answer

Is it expecting a raw print queue? Eltron (and Zebra) can use their own EPL2 or ZPL language that has to be passed as RAW (In *NIX lp -o raw testlabel.epl2). If you can get some labels out from notepad it's probably using a print driver, but your business software may be trying to send it EPL2 (or ZPL) code.
I've got all our Eltron's listed twice in CUPS, once with the Eltron driver and once as RAW.

share|improve this answer

The barcode software my company uses for our Zebra Barcode printers passes the data in ZPL. We use a Slackware based OS using CUPS or lprng. We just have to have the correct printername, IP and set the printer to RAW(cups) RAW2(printcap lprng).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.