Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an iMac running Mac OS X 10.5.8 and the RDP Connection Client 2.0.1.

When I try to connect to a Windows 2003 Server on the same network I get a dialog saying "Remote Desktop Connection cannot verify the identity of the computer that you want to connect to".

And when I press the Connect-button in the previous dialog I get the same message in another dialog:

I can connect to the Win2k3 server from a Vista machine, and it used to work from the Mac as well. I stopped working from the Mac after I did some configuration on the win2k3 server, removed and added the the connection in the Terminal Services Configuration:

What do I need to do to be able to connect from the Mac again?

share|improve this question
    
The first dialog is definitely expected, since you are connecting to a 2003 server. –  Kyle Smith Oct 18 '09 at 16:26

5 Answers 5

In Remote Desktop on your Mac open Preferences -> Security.

Make sure that the first 'Always Connect' option is chosen.

After that, you might want to try CoRD (http://cord.sourceforge.net/), which is an open-source Remote Desktop client that has some better tweaks and error messages.

share|improve this answer
    
I tried selecting "Always Connect" in the Remote Desktop Client but still couldn't connect (the same message). Then I tried CoRD as you suggested, but when trying to connect nothing happens, no dialog no nothing... –  user23294 Oct 19 '09 at 18:44
    
Remote Desktop Client didn't work at all.. but CoRD did, thanks!! –  yorch Dec 18 '12 at 21:39

CoRD solved my problem, and some other minor problems too :) I recommend it!

share|improve this answer

We just had this same issue with a WS2008R2 and a Mac. Connected from mac via microsofts RDP program. Suddenly disconnected with that message. Subsequent attempts at logon from Mac gave same message and immediate disconnection.

Settings on the server were as user23294 mentioned, set to compatible, and the setup has worked fine up till now (many months).

Solution was to logon from a windows client, close programs and log user off.

Then the user could again log on from a Mac.

Apparently the user session became corrupted somehow, preventing access from a Mac, but not from another Windows client.

share|improve this answer

Solved it, I changed encryption level on the connection in the Terminal Services Configuration dialog to "Client Compatible".

http://salle.dyndns.org/misc/rdp%5Fproblem%5Fsolution.png

share|improve this answer

I was having the same problem. The authentication would fail if the user had the password saved in the settings. It's a security risk having the password saved but the error message is so cryptic and my users just can't get the hang of not saving their password when it asks to save the connection at the end of the session.

If you can accept the security risk of a saved password on the client end, then I turned off the "Always prompt for password" on the "Log On Settings Tab" in "RDP-Tcp Properties" of "Remote Desktop Session Host Configuration" -- Windows 2008 R2.

This resolved the problem for me but it's a security compromise to not alienate the Mac people.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.