Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Getting pages on my apache is currently unacceptably slow, even locally. I have no clue what may be going on, but the processors seem pretty inactive, and there are 7GB of free memory. Any ideas? Take a look at this time/curl test:

muiraquitã 3:49 ~ % time curl 127.0.0.1
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /index.html
on this server.</p>
<hr>
<address>Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3 with Suhosin-Patch Server at 127.0.0.1 Port 80</address>
</body></html>
**curl 127.0.0.1  0.00s user 0.00s system 0% cpu 17.768 total**
share|improve this question
    
Anything special about your config? Custom authentication modules, proxy rules, etc? Where are the files? Local, or remote like NFS or on a SAN? What is the system? Virtual, or bare metal? –  Jeff Snider Oct 19 '09 at 2:39
    
Any update on this? Did you find a resolution? –  Jeff Snider Oct 21 '09 at 4:37

2 Answers 2

That kinda smells like DNS lookup timeouts. Try turning off HostnameLookups and see whether that improves the situation.

share|improve this answer
    
Hmm, it was already off on apache2.conf :( –  user21690 Oct 19 '09 at 2:08

If you disable access restriction to index.html do you get better results ? Do you use NIS or serve / from a remote filesystem or some raid rebuild is in progress ? index.html is static or dynamic generated content ?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.